Opened 4 years ago

Closed 4 years ago

#2640 closed defect (fixed)

Missing preference for notification opt-out is causing error

Reported by: sebastian Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-1.9-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5911246494760960

Description

How to reproduce

Load any website (e.g. https://google.com).

Observed behaviour

Following error message is logged in the background page:

Error in event handler for webRequest.onHeadersReceived/2: TypeError: Cannot read property 'indexOf' of undefined
    at Object.require.scopes.notification.exports.Notification.getNextToShow (chrome-extension://ionebeimagjmhfodcbeeplpiiboaabgl/lib/adblockplus.js:3891:116)
    at onHeadersReceived (chrome-extension://ionebeimagjmhfodcbeeplpiiboaabgl/webrequest.js:102:50)

Also notifications won't show up. This happens since the adblockplus dependency was updated (#2639). A change imported with that update (#2192) relies on Prefs.notifications_ignoredcategories, however that preference hasn't been added added yet.

Expected behaviour

No error should show up in the background page log. Notifications should be shown.

Change History (3)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sebastian

@greiner: Please make sure that required changes in the platform module are implemented, either prior to, or along with the dependency update, next time.

comment:3 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.