Opened 4 years ago

Closed 4 years ago

#2665 closed defect (fixed)

Spanish translations aren't used in Opera builds

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5181140172275712

Description (last modified by sebastian)

Environment

Adblock Plus, any version including 1.8.12 and current development build
Opera 29

How to reproduce

  1. Switch UI language to es or es_419 (On Linux: LANGUAGE=es opera)
  2. Install Adblock Plus

Observed behaviour

While Opera's own user interface is shown in Spanish, the user interface of Adblock Plus including the first run page, options page and icon popup is in English.

That is because the locales aren't mapped for the Opera build as we do for the Chrome build (e.g. es_ES=>es, es_MX=>es_419). However, since Opera is based on Chromium as well they use the same locales. That means there is an es local for Spanish (Spain) and es_419 for Spanish used outside of Spain. But no es_ES which we currently have in the Adlock Plus for Opera build.

Expected behaviour

The Adblock Plus user interface should support Spanish on Opera.

Therefore locales must be mapped the same way they are mapped for Chrome.

Change History (4)

comment:1 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:2 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

For reference, it seems that Chromium-based Opera did use different locale codes for Spanish at some point in the past, or at least we assumed so. My patch is removing code that explicitly mapped es to es_ES and dumped es_419 for the Opera build.

comment:3 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:4 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.