Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#267 closed defect (incomplete)

Non advertise iframe is blocked.

Reported by: dearprint Assignee:
Priority: Unknown Milestone:
Module: Extensions-for-Adblock-Plus Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

I have posted at forum.
https://adblockplus.org/forum/viewtopic.php?f=11&t=22469&sid=3ce3965a4ebcdb0efab47b1deacb7c95


I am developing a Chrome Extension.
The extension page is
https://chrome.google.com/webstore/detail/images-to-pdf/fkcddcfdmiebmhabfipjlnkkeokdlbom

This extension use image editor "pixlr api" in iframe.(https://pixlr.com/developer/api/‎)
It dose not work, when Adblock Plus is active.

When I click "Edit" button of each image, with Adblock Plus active

  1. an iframe is created
  2. src is "http://pixlr.com/editor/?..."
  3. iframe dose NOT loaded,

4 "Failed to load resource: net::ERR_BLOCKED_BY_CLIENT"
or "GET http://pixlr.com/editor/?... net::ERR_BLOCKED_BY_CLIENT" is in Chrome Console.

When I stop the Adblock Plus, its works fine.

Are there any methods to avoid blocking?

Change History (4)

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added
  • Description modified (diff)

comment:2 Changed 6 years ago by philll

  • Resolution set to invalid
  • Status changed from new to closed

Apparently, I cannot reproduce this currently with Chrome Version 33.0.1750.154 and ABP 1.7.4.1141. Trying your extension at http://web.de offered me to click the edit button at the listed images and get the Photoshop-like edit interface, which works fine as far as I tested it a bit.

Which website did you use for testing this and which Versions of Chrome and ABP do you use with which filter lists?

Please reopen the issue if you added this information.

comment:3 follow-up: Changed 6 years ago by dearprint

Thank you very much for your response and checking.
My cheking PC is Windows8.1, Chrome 34.0.1847.92, ABP 1.7.4.
When I disabled all other extensions except for ABP and my extension, my extension works well.
I'm so sorry for taking your time.

comment:4 in reply to: ↑ 3 Changed 6 years ago by philll

Replying to dearprint:

Thank you very much for your response and checking.
My cheking PC is Windows8.1, Chrome 34.0.1847.92, ABP 1.7.4.
When I disabled all other extensions except for ABP and my extension, my extension works well.
I'm so sorry for taking your time.

Which website did you use for testing this and which filter lists are installed and active in ABP?

Note: See TracTickets for help on using tickets.