Opened 4 years ago

Closed 4 years ago

#2681 closed defect (fixed)

Thunderbird versions on requirements page listed twice if beta and stable channel are on the same version

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone:
Module: Websites Keywords:
Cc: saroyanm Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29317012

Description (last modified by sebastian)

How to reproduce

Go to http://localhost:5000/en/requirements/.

Observed behaviour

Currently, Thunderbird 38.0 and Thunderbird 38 are listed. That is because both the stable and beta channel is on 38 now. For other applications listed this is handled and the beta channel isn't listed redundantly, if it's on the same version as the stable. However, that logic doesn't work here, since we include the minor version for Thunderbird stable releases, but not for Thunderbird test releases.

Expected behaviour

Don't list Thunderbird test release that are on the same version as the receptive stable channel.

Change History (6)

comment:1 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by saroyanm

Thunderbird 31.0 and Thunderbird 31
Isn't it Thunderbird 38.0 and 38 ?

comment:3 Changed 4 years ago by saroyanm

  • Cc saroyanm added

comment:4 Changed 4 years ago by sebastian

  • Description modified (diff)

You are right. Corrected.

comment:5 Changed 4 years ago by sebastian

  • Description modified (diff)

comment:6 Changed 4 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.