Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#2686 closed defect (fixed)

[Adblock Browser for iOS] - [Bookmarks] - Icons don't update after the website bookmarked has been edited

Reported by: Shikitita Assignee:
Priority: P4 Milestone: Adblock-Browser-for-iOS-1.3.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: jand, pavelz, vojtab, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

Description (last modified by Shikitita)

Environment

Platform: iPhone 5s
Operating System: iOS 8.3
Browser: Adblock Browser 0.7.0

How to reproduce

  1. With Adblock Browser open, tap on the icon at the bottom right corner of the screen and then tap on the cross in order to open a new tab.
  2. Tap on the URL bar at the top of the screen where it says "Search or enter website name" and enter a website's address (e.g: youtube.com, google.co.uk or wikipedia.org).
  3. Tap on the star at the bottom of the screen in order to bookmark that website.
  4. After this, tap on the icon at the bottom right corner of the screen and then tap on the cross in order to open a new tab.
  5. Swipe the screen to the left where the bookmarks are and touch and hold the existent bookmark for a few seconds in order for a menu to pop up.
  6. Select Edit.
  7. In the following screen change the URL of the bookmarked website for an existing one.
  8. Tap on "Done" and then tap on the bookmarked website in order to load it.
  9. Afterwards repeat the steps on number 4 and swipe the screen to the left in order to view the Bookmarks section.

Observed behaviour

The icon of the bookmark does not correspond to the icon of the website bookmarked despite having loaded it after editing it. See the attached screenshot.

Expected behaviour

The bookmark's icon should change to the corresponding one after loading the website.

Attachments (1)

IMG_00011.PNG (107.2 KB) - added by Shikitita 5 years ago.
Wrong icons for bookmarks

Download all attachments as: .zip

Change History (20)

Changed 5 years ago by Shikitita

Wrong icons for bookmarks

comment:1 Changed 5 years ago by Shikitita

  • Description modified (diff)

comment:2 Changed 5 years ago by Shikitita

  • Description modified (diff)

comment:3 Changed 5 years ago by Shikitita

  • Summary changed from [Adblock Browser] - [Bookmarks] - Icons don't update after the website bookmarked has been edited to [Adblock Browser for iOS] - [Bookmarks] - Icons don't update after the website bookmarked has been edited

comment:4 Changed 4 years ago by philll

  • Cc jand pavelz vojtab added

comment:5 Changed 4 years ago by philll

  • Platform changed from Kitt to Adblock Browser for iOS

comment:7 Changed 4 years ago by pavelz

Unusual and uncommon corner case. None of the major iOS browsers reflects changes in already created bookmark. Safari and Chrome keep the previous page title even when the new page is loaded. Opera even does not allow changing URL of an existing bookmark. Neither of the browsers display favicon in the listing.

comment:8 Changed 4 years ago by pavelz

Interesting philosophical question: if URL is changed and title is changed too (perhaps just simplified), what should happen to the title when the new page is loaded? Should the user editing be thrown away and replaced with the new title? I think that Opera got it right by avoiding the need for such fragile decision logic.

comment:9 Changed 4 years ago by philll

  • Sensitive unset

comment:10 Changed 4 years ago by mario

  • Cc mario added
  • Priority changed from Unknown to P4

Lowered priority due to the fact, that ABB behaves like other major browsers for iOS. Nonetheless I see value in this issue and wouldn't discard it. Feel free to discuss it and change the issue to a higher priority.

comment:11 Changed 4 years ago by mario

  • Component changed from Unknown to Adblock-Browser-for-iOS

comment:12 Changed 4 years ago by mario

  • Keywords salsita added

comment:13 Changed 4 years ago by jand

@mario: I have already implemented this issue. I noticed that it is not marked ready. Can you finalize this issue, please?

comment:14 Changed 4 years ago by mario

  • Ready set

comment:15 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:16 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

comment:17 Changed 4 years ago by mario

  • Milestone Adblock-Browser-for-iOS-next deleted

comment:18 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next

Rebased the current release branch to include this ticket.

comment:19 Changed 4 years ago by scheer

  • Tester changed from Unknown to Scheer
  • Verified working set
  • The bookmark's icon changes to the correct icon after loading the website.

ABB 1.3.0-qa (844)
iPhone 6 Plus - iOS 9.2.1

Note: See TracTickets for help on using tickets.