Opened 6 years ago

Closed 5 years ago

#269 closed defect (worksforme)

Notification Icon "Waiting For Traffic On Port 2020" [Wireless setting already set with "Proxy: localhost" and "Port: 2020"]

Reported by: hetsang Assignee: rjeschke
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: smultron45@… Blocked By:
Blocking: Platform: Android
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Android Phone: Samsung Galaxy S4|SGH-M919
Android Version: 4.3
Adblock Plus Version: 1.2.1.319|Build #: 319
Filter lists: EasyList

Observed behaviour

The Adblock Plus notification icon shows that it is "Waiting For Traffic On Port 2020" even though Adblock Plus is working (I know that ABP is working because ads are actively being blocked). I have also manually entered in ‘localhost’ for the proxy and ‘2020’ for the port.

As long as Adblock Plus is “On”, there is an icon that shows that message. I tried restarting the phone, restarting AdblockPlus by force stop and re-opening ABP, re-entering the proxy and port for the wireless internet setting. But nothing was successful in having the application sense that traffic is passing through port 2020. Once again, ABP is working and blocking ads.

I even checked off “Hide icon” in the ABP app to adopt a transparent icon but I guess that would not work when the application thinks that traffic is not passing through the port.
So… I just uncheck “Show Notification” in “Setting>Application Manager>Adblock Plus application info” to remove the notification completely but every time AdBlock Plus application crashes or if I restart the phone, the notification “Waiting For Traffic On Port 2020” returns despite having turned off the notification under “Setting>Application Manager>Adblock Plus application info”. So then, I would have to go there again, enable notification then disable notifications to remove the ABP notification icon whenever it crashes or I restart my phone.

I installed Adblock Plus For Android version 1.2 before I updated to version 1.2.1.319. Both of those versions had this problem so I wanted to make awareness of this issue.

Expected behaviour

I expect the notification of “Waiting For Traffic On Port 2020” to be removed as soon as ‘localhost’ and ‘2020’ was entered into the proxy and port respectively. Additionally, I, at least, expected the option to not “Show Notifications” under “Setting>Application Manager>Adblock Plus application info” to continue to hide the notification after application crashes or phone restarts.
Please fix the issue so that the application can properly detect that traffic is passing through the port so that the notification disappears.

Please fix the application so that the notification will still be hidden after restarting the phone when the “Show notification” is unchecked as well.

Thank you.

Attachments (4)

SS1.png (205.0 KB) - added by hetsang 6 years ago.
Picture of Notification
SS2.png (203.6 KB) - added by hetsang 6 years ago.
Picture showing Adblock filtering is enabled; Option to hide icon checked; Notification still present
SS3.png (216.5 KB) - added by hetsang 6 years ago.
Picture of WIFI turn "On" with settings with Proxy: localhost & Port:2020; Notification still present
SS4.png (245.8 KB) - added by hetsang 6 years ago.
Picture after phone restarted; ABP application info (Version number shown also) with "Show notifications" unchecked; Notification "Waiting for traffic on port 2020" still present

Download all attachments as: .zip

Change History (13)

comment:1 Changed 6 years ago by mapx

  • Cc smultron45@… added

Changed 6 years ago by hetsang

Picture of Notification

Changed 6 years ago by hetsang

Picture showing Adblock filtering is enabled; Option to hide icon checked; Notification still present

Changed 6 years ago by hetsang

Picture of WIFI turn "On" with settings with Proxy: localhost & Port:2020; Notification still present

Changed 6 years ago by hetsang

Picture after phone restarted; ABP application info (Version number shown also) with "Show notifications" unchecked; Notification "Waiting for traffic on port 2020" still present

comment:2 in reply to: ↑ description Changed 6 years ago by hetsang

Phone is NOT rooted.

Last edited 6 years ago by hetsang (previous) (diff)

comment:3 Changed 6 years ago by philll

  • Owner set to rjeschke
  • Status changed from new to assigned

comment:4 Changed 6 years ago by philll

  • Status changed from assigned to new

The assigned state will be dropped by #403

comment:5 Changed 5 years ago by philll

  • Platform set to Unknown

We finally got an S4 testing device. However, with its installed Android 4.4.2 and the current ABP dev build 328, your issue doesn't occur there. I noticed that you are using some surface/font modification. What is it exactly? Maybe, it's related here.

comment:6 Changed 5 years ago by rjeschke

The no-traffic check has been redesigned during the latest changes, so this issue should be fixed. And as I can not reproduce it, I'll close it as 'fixed'.

comment:7 Changed 5 years ago by rjeschke

  • Platform changed from Unknown to Android
  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 5 years ago by trev

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening to change the resolution - if this wasn't fixed there, the resolution should be "works for me."

comment:9 Changed 5 years ago by trev

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.