Opened 4 years ago

Closed 4 years ago

#2695 closed defect (invalid)

Problems loading page content when ABP is enabled

Reported by: AeroZ Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: sebastian, mapx Blocked By:
Blocking: Platform: Safari
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Environment

OSX 10.10.3
Safari 8.0.6
ABP 1.9.0.1.456 (also tried with latest non-development build)
EasyList only without any custom filters

How to reproduce

  1. Go to www.idownloadblog.com or www.cultofmac.com
  2. Start scrolling down on the page

Observed behaviour

Page content appears after a notable delay, while the adcounter increases slowly. When Adblock Plus is not installed the content shows up immediately.

Expected behaviour

The page content should show up immediately when scrolling.

Change History (6)

comment:1 Changed 4 years ago by mapx

  • Cc sebastian mapx added

comment:2 Changed 4 years ago by sebastian

  • Cc Ross added

@Ross: Mind trying to reproduce this issue? And if it is reproducible, it would also be good to know whether it is a regression (whether it didn't occur with Adblock Plus 1.8.12).

comment:3 Changed 4 years ago by AeroZ

The issue occurs every time. Even if I just refresh the page.

Could you provide a download link for Adblock Plus 1.8.12, please?

comment:4 Changed 4 years ago by sebastian

https://hg.adblockplus.org/downloads/raw-file/bee8ab1f6e79/adblockplussafari-1.8.12.safariextz

(You might need to disable automatic extension updates first, that Safari doesn't update you to 1.9)

Last edited 4 years ago by sebastian (previous) (diff)

comment:5 Changed 4 years ago by AeroZ

Yeah, I disabled automatic updates first. Tho the problem is still there with 1.8.12.
For example with www.idownloadblog.com. When I go to that page then the initial view shows up as normal. Now when I start scrolling down the page is just grey (no content other than the background), the number of blocked adds on ABP's icon slowly increases and then about 10 seconds later the page content is starting to show up.

comment:6 Changed 4 years ago by sebastian

  • Cc Ross removed
  • Description modified (diff)
  • Resolution set to invalid
  • Status changed from new to closed

Reproduced. Same when Adblock Plus is disabled on that page, or when no filter lists are used. There is a delay of a copule of seconds before the page content shows up after scrolling.

I looks like the messaging between the content script and background page being slow is causing this, also considering that quite a lot of requests, some with quite long URL, are sent on those pages. So it seems there isn't much we can do here, the way content blocking currently works on Safari.

Note: See TracTickets for help on using tickets.