Opened 4 years ago

Closed 4 years ago

#2696 closed defect (invalid)

When filter subscription is added, "Failed, download failure" is displayed.

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Shikitita, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-133

Environment

Windows + 8 64bit + Firefox + English
ABP version 2.6.9.3935

How to reproduce

  1. Add the 'ABP' plugin to the Firefox browser.
  1. Make sure that there is no internet connection.
  1. Click on 'ABP" icon -> Filter Preferences.
  2. Click on 'Add filter subscription' and add 'EasyList'.
  1. Observe that 'Failed, download failure' is displayed.
  1. Make sure that there is internet connection.
  1. Delete the 'EasyList' filter subscription.
  1. Add again 'EasyList' filter subscription.

Observed behaviour

'Failed, download failure' is displayed.

Expected behaviour

'EasyList' filter subscription is downloaded successfully.

Attachments (1)

3766_1431509590_firefoxListFail.png (148.5 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 13 May 2015 09:33:51 posted by Rajeswari Vemuri
I raised similar ticket ACH-83 earlier for chrome browser.

2 - 19 Jun 2015 09:56:26 posted by Tamara Blasco
Could you please let us know if this issue is still ocurring?

Were you also using Firefox ESR when this issue was reported?

Any extra information will be appreciated.

Thanks

comment:2 Changed 4 years ago by Shikitita

  • Description modified (diff)

comment:3 Changed 4 years ago by sebastian

  • Cc Shikitita sebastian added
  • Resolution set to duplicate
  • Status changed from new to closed

Why did you approve that bug in the first place, if you already knew that it's a duplicate?

(Also note that you can simply type #1504 instead the full URL of the issue)

Last edited 4 years ago by sebastian (previous) (diff)

comment:4 Changed 4 years ago by Shikitita

While this issue is for Firefox, 1504 is for Chrome, which was reported in October, whereas this one was reported last month. Furthermore, I managed to reproduce it last week, so I thought as it being more recent it was worth looking into it.

Thanks for the tip about the link!

comment:5 Changed 4 years ago by sebastian

A bug can occur on multiple platforms. Having separate issues for each platform isn't helpful. Also it doesn't matter when the bug was reproduced first.

Last edited 4 years ago by sebastian (previous) (diff)

comment:6 Changed 4 years ago by trev

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I cannot see how this is a duplicate. #1504 complains about subscription download failing if subscription is canceled while download is in progress. This issue is about subscription state persisting if a subscription is removed and the re-added. #1504 would be a bug if I could reproduce it. This one is really by design - we don't start a new download after a failure, it has to be triggered manually. And removing a subscription doesn't clear its state.

comment:7 Changed 4 years ago by trev

  • Resolution set to invalid
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.