Opened 4 years ago

Closed 4 years ago

#2697 closed defect (invalid)

[ABP for FF] - [Filter pref.] "Restore backup" function doesn't seem to work

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-118

Environment

Windows + 8 64bit + Firefox + Russian
ABP version 2.6.9.3930

How to reproduce

1) Download Mozilla 37.0.1
2) Download ABP.
3) Click ABP icon.
4) Click filter's setings.
5) Click "backup and restore".
6) Click "restore copy".

Observed behaviour

There is error message.

Expected behaviour

There is not error message.

Attachments (3)

7058_1428610186_restore_copy1.jpg (159.3 KB) - added by passbrains 4 years ago.
7058_1428610186_restore_copy2.jpg (272.5 KB) - added by passbrains 4 years ago.
patterns-backup1.ini (39 bytes) - added by Shikitita 4 years ago.
Automatic backup file

Download all attachments as: .zip

Change History (13)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 19 Jun 2015 13:20:54 posted by Tamara Blasco
Please note that the file ABP is trying to restore appears to lack information in order for the software to be able to execute it.

comment:2 Changed 4 years ago by Shikitita

  • Description modified (diff)
  • Summary changed from Problem with restore backup. to [Adblock Plus] - [Firefox] - [Filter preferences] "Restore backup" function doesn't seem to work

comment:3 Changed 4 years ago by Shikitita

  • Summary changed from [Adblock Plus] - [Firefox] - [Filter preferences] "Restore backup" function doesn't seem to work to [ABP for FF] - [Filter pref.] "Restore backup" function doesn't seem to work

comment:4 Changed 4 years ago by greiner

  • Cc greiner added
  • Component changed from Unknown to Adblock-Plus-for-Firefox

I couldn't reproduce this on my machine so could you please attach the corrupted backup file to this ticket?

Changed 4 years ago by Shikitita

Automatic backup file

comment:5 follow-up: Changed 4 years ago by Shikitita

The file above is the file generated automatically by ABP as soon as the software is installed, as per the Steps to Reproduce in this issue. However, its size is less than 1MB and with no information to restore, for which reason the following error message pops up on the screen: "The file's data could not be processed, maybe this isn't an Adblock Plus backup file?".

Last edited 4 years ago by Shikitita (previous) (diff)

comment:6 in reply to: ↑ 5 Changed 4 years ago by greiner

  • Resolution set to invalid
  • Status changed from new to closed

Replying to Shikitita:

The file above is the file generated automatically by ABP as soon as the software is installed, as per the Steps to Reproduce in this issue. However, its size is less than 1MB and with no information to restore, for which reason the following error message pops up on the screen: "The file's data could not be processed, maybe this isn't an Adblock Plus backup file?".

The file format appears to be ok but the provided file is empty i.e. doesn't contain any filters or filter lists. Therefore I'd consider this issue invalid since the restore functionality appears to be working as intendend.

comment:7 follow-up: Changed 4 years ago by philll

  • Resolution invalid deleted
  • Status changed from closed to reopened

Wow - setting this issue to invalid simply because the describes symptoms aren't the bug itself seems very wrong to me. We should find the underlying issue and fix this accordingly.

comment:8 in reply to: ↑ 7 Changed 4 years ago by greiner

Replying to philll:

Wow - setting this issue to invalid simply because the describes symptoms aren't the bug itself seems very wrong to me. We should find the underlying issue and fix this accordingly.

The issue mentioned in here is invalid. The issue that led to the creation of that empty backup file is independent of this issue especially since the ticket doesn't even mention where that file comes from.
Therefore I'd rather tackle this in a separate ticket instead of completely rewriting the entire ticket.

comment:9 Changed 4 years ago by philll

@greiner: I'm fine with that (Although not really seeing the big advantage), so please provide that new issue and then feel free to invalidate this here, after having linked to the new one.

comment:10 Changed 4 years ago by greiner

  • Resolution set to invalid
  • Status changed from reopened to closed
  • Tester set to Unknown

Created a new ticket at #2768. Since I cannot reproduce it myself, I just reused the instructions from this ticket but leaving out the parts about restoring the backup.

Note: See TracTickets for help on using tickets.