Opened 4 years ago

Closed 4 years ago

#2698 closed defect (worksforme)

Notifications do not display included links

Reported by: Ross Assignee:
Priority: P2 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: greiner Blocked By:
Blocking: #2162 Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Ross)

Environment

ABP 2.6.9.3953
Firefox 38.0.5 / Windows 8.1 x64

How to reproduce

  1. Set up the notification below on the server.
  2. In Firefox, navigate to about:config.
  3. Reset the adblockplus.notificationdata key.
  4. Restart Firefox.
  5. Wait one minute for the notification data to be fetched.
  6. Observe the response includes the link as expected.
  7. Observe the notification displayed by ABP does not display the link.

Test data

  severity = information
  target = extension=adblockplus
  title.en-US = Test notification
  message.en-US = Test notification with link
  links = adblock_browser_android_beta_community

Observed behaviour

The notification displayed by ABP does not display the link.

Expected behaviour

The notification displayed by ABP should display the link.

Attachments (1)

Notification.png (19.7 KB) - added by Ross 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by Ross

comment:1 Changed 4 years ago by fhd

  • Resolution set to rejected
  • Status changed from new to closed

That is actually by design: Notifications can only show "doc links". Meaning. links reachable via https://adblockplus.org/redirect?link=foo.

For example, the entry:

links = adblock_browser_android_beta_community

Would end up linking to: https://adblockplus.org/redirect?link=adblock_browser_android_beta_community

comment:2 follow-up: Changed 4 years ago by Ross

  • Blocking 2162 added
  • Description modified (diff)
  • Resolution rejected deleted
  • Status changed from closed to reopened

Retested with "doc links". They are still not displayed in the notification at all.

comment:3 in reply to: ↑ 2 Changed 4 years ago by greiner

  • Cc greiner added

Replying to Ross:

Retested with "doc links". They are still not displayed in the notification at all.

The message doesn't contain any <a> tags. Note that not only do you need to specify where it should link to but also which part of the text should be hyperlinked.

e.g. Test notification with <a>link</a>

comment:4 Changed 4 years ago by Ross

  • Resolution set to worksforme
  • Status changed from reopened to closed

Ah, that makes sense and works as expected (tested single and multiple links).

ABP 2.6.9.3953
Firefox 38.0.5 / Windows 8.1 x64

comment:5 Changed 4 years ago by fhd

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Tester set to Unknown

comment:6 Changed 4 years ago by fhd

  • Resolution set to worksforme
  • Status changed from reopened to closed

Woops, sorry, closing again.

Note: See TracTickets for help on using tickets.