Opened 4 years ago

Closed 4 years ago

#2707 closed defect (fixed)

Notification start / end keys do not work

Reported by: Ross Assignee: fhd
Priority: P3 Milestone:
Module: Sitescripts Keywords:
Cc: trev, fhd, sebastian Blocked By:
Blocking: #2162 Platform: Unknown
Ready: yes Confidential: no
Tester: Ross Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29321041/
https://codereview.adblockplus.org/29322888/

Description

Environment

ABP 2.6.9.3953
Firefox 38.0.5 / Windows 8.1 x64

How to reproduce

  1. Set up the notification below on the server.
  2. Commit the new notification.
  3. Visit <Server>/notification.json

Test data

  start = 2015-06-17T11:00
  end = 2015-06-28T11:00
  severity = information
  target = extension=adblockplus
  title.en-US = Test notification
  message.en-US = Test notification 

Observed behaviour

The notification is not generated and included in notification.json, even if the date range is valid.

Expected behaviour

The notification should be generated and included in notificaton.json, if the date range is valid.

Change History (9)

comment:1 Changed 4 years ago by sebastian

  • Cc trev fhd sebastian added

From looking as the code and version history, it seems that the startand end paramter was never actually supported.

comment:2 Changed 4 years ago by fhd

  • Owner set to fhd
  • Ready set

Yes, wasn't implemented. No big deal though, I'll look into that.

comment:3 Changed 4 years ago by fhd

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 4 years ago by sebastian

  • Priority changed from Unknown to P3

comment:5 Changed 4 years ago by fhd

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 4 years ago by Ross

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester set to Ross

This still doesn't work as expected. It seems like if the start/end keys are present, the notification is not included in the response at all. Notification file/keys looked okay.

Have tried:

  • Using valid start/end keys.
  • Using just a valid start key.
  • Using just a valid end key.
  • Mix of invalid keys.

ABP 2.6.9.3953
Firefox 38.0.5 / Windows 8.1 x64

comment:7 Changed 4 years ago by fhd

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

Yup, there was indeed still a problem :/ New review up to fix that.

comment:9 Changed 4 years ago by fhd

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.