Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2710 closed defect (fixed)

Share dialog fails to open on first-run page

Reported by: passbrains Assignee: greiner
Priority: P2 Milestone:
Module: User-Interface Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29322728/
https://codereview.adblockplus.org/29322731/

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-138

Environment

Windows + 8 64bit + Firefox + English
ABP version 2.6.9.3945

How to reproduce

  1. Go to chrome://adblockplus/content/ui/firstRun.html
  2. Click on Facebook, Twitter or Google+ icon. 

Observed behaviour

Share dialog is not opened.

Expected behaviour

Share dialog is opened.

What to change

adblockplusui

share.adblockplus.org

What to test

Clicking on social media icon on first-run page in each of the following platforms should open the share dialog:

  • Chrome / Opera / Safari (requires dependency update)
  • Firefox 29
  • Firefox 42
  • Firefox Mobile
  • SeaMonkey
  • Thunderbird

Attachments (1)

3766_1433067823_firefoxSocial.mp4 (262.7 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (12)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 31 May 2015 10:24:47 posted by Rajeswari Vemuri
Similar to AFI-37

comment:2 Changed 4 years ago by Shikitita

  • Description modified (diff)

Reproduced on the Testfabrik machine Win vista 64 bit slot 5 with Firefox 38.0.5. Spotted the following output in the java script console when clicking one of the social media icons:

Error: Permission denied to access property "postMessage" en:132:4
Error: Permission denied to access property "postMessage" widgets.js:1:18086
"Invalid App Id: Must be a number or numeric string representing the application id." all.js:64:238
"FB.getLoginStatus() called before calling FB.init()." all.js:64:238
TypeError: a is undefined plusone.js:43:791
Diese Website verwendet ein SHA-1-Zertifikat; es wird empfohlen, Zertifikate mit Signaturalgorithmen zu verwenden, die stärkere Hashfunktionen verwenden als SHA-1.[Weitere Informationen] badge
Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead rs=AGLTcCMcKSJXdPyjlQBxpi--mrC8VUXzXQ:90:0
Using //@ to indicate sourceURL pragmas is deprecated. Use //# instead rs=AGLTcCMcKSJXdPyjlQBxpi--mrC8VUXzXQ:273:0
getAttributeNode() sollte nicht mehr verwendet werden. Verwenden Sie stattdessen getAttribute(). rs=AGLTcCMcKSJXdPyjlQBxpi--mrC8VUXzXQ line 6 > eval:35:0
Diese Website verwendet ein SHA-1-Zertifikat; es wird empfohlen, Zertifikate mit Signaturalgorithmen zu verwenden, die stärkere Hashfunktionen verwenden als SHA-1.[Weitere Informationen] like.php
TypeError: a is undefined plusone.js:43:791

comment:3 Changed 4 years ago by greiner

  • Component changed from Unknown to User-Interface
  • Priority changed from Unknown to P2

This issue appears to be the same as the one reported at Bugzilla earlier this year. The share.adblockplus.org page is running in an unprivileged window and wants to communicate with its parent frame which is a privileged window by using window.parent.postMessage.

The suggested approach on that thread is to use WebChannel instead which requires changes on both ends of the line.

comment:4 Changed 4 years ago by greiner

  • Cc greiner added
  • Description modified (diff)
  • Ready set
  • Summary changed from 'Think Adblock plus worth sharing' is not opened when clicked on social media icons on first run page. to Share dialog fails to open on first-run page

comment:5 Changed 4 years ago by greiner

  • Owner set to greiner

comment:6 Changed 4 years ago by greiner

  • Description modified (diff)

Simplified the ticket description a bit.

comment:7 Changed 4 years ago by trev

It looks like WebChannel will only work in Firefox, not in SeaMonkey or Firefox Mobile. That should to be tested because it won't work for us as solution then.

comment:8 Changed 4 years ago by greiner

  • Keywords externaldependency added

This behavior appears to be a regression introduced in Firefox 38. I filed bug 1177795 at Bugzilla.

comment:9 Changed 4 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing
  • Tester set to Unknown

comment:10 Changed 4 years ago by greiner

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:11 Changed 4 years ago by trev

  • Keywords externaldependency removed
  • Milestone Adblock-Plus-for-Firefox-next deleted

Removed milestone - this won't get into release automatically, a dependency update is needed.

Note: See TracTickets for help on using tickets.