Opened 4 years ago

Closed 4 years ago

#2717 closed defect (invalid)

All "Add Adblock Plus filter rule" dialog boxes are closed when clicked on "Cancel" of last dialog box.

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-127

Environment

Windows + 8 64bit + Firefox + English
ABP version 2.6.9.3932

How to reproduce

  1. Install ABP extension.
  2. Load any website http://timesofindia.indiatimes.com/
  3. Right-click on any image and choose "Adblock Plus: Block image...".
  4. Observe that "Add Adblock Plus filter rule" dialog box opens up. 
  5. Again Right-click on any other image and choose "Adblock Plus: Block image...".
  6. Observe that another "Add Adblock Plus filter rule" dialog box opens up. 
  7. Click on "Cancel" of last dialog box.

Observed behaviour

All dialog boxes are closed. When right-clicked on any image and choose "Adblock Plus: Block image...", all dialog boxes appear again.

Expected behaviour

Only last dialog box is closed.

Attachments (1)

3766_1429865142_firefoxMultiple.mp4 (1.1 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 29 Apr 2015 12:01:52 posted by Timo Scherf
Reproduced, but I am not sure if this is working as desgned

comment:2 Changed 4 years ago by greiner

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Description modified (diff)

comment:3 Changed 4 years ago by Shikitita

  • Cc trev added
  • Component changed from Adblock-Plus-for-Firefox to Unknown
  • Description modified (diff)

comment:4 Changed 4 years ago by greiner

  • Component changed from Unknown to Adblock-Plus-for-Firefox

comment:5 Changed 4 years ago by Shikitita

Could this be by design or maybe intended?

It is not an issue per se, but I would like to give feedback to the tester in regards of this. Also, wouldn't it be better to change the functionality so that each window, when open, has to be closed/cancelled individually? Just a thought.

comment:6 Changed 4 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

No, we don't cancel multiple windows at once, and we don't show them again magically. When the OP cancelled the dialog the Firefox window became focused again. As a result, the other two dialogs got hidden behind the Firefox window. When he opened another window the Firefox window moved into background and these dialogs became visible again. Maybe Windows behaving that way isn't obvious to everybody - but that isn't something we are responsible for.

Note: See TracTickets for help on using tickets.