Opened 4 years ago

Closed 4 years ago

#2725 closed defect (worksforme)

Filter subscription list is empty when ABP installation is repeated.

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ARE-130

Environment

Windows + 8 64bit + Firefox + English
ABP version 2.6.9.3935

How to reproduce

  1. Uninstall the ABP plugin.
  2. Install the latest ABP plugin.
  3. Uninstall the ABP plugin.
  4. Delete "adblock plus" user files folder.
  5. Repeat the installation of latest ABP plugin.

Observed behaviour

Filter subscription list is empty.

Expected behaviour

Filter subscription list is not empty when ABP installation is repeated.

Attachments (1)

3766_1431459810_firefoxList.mp4 (2.3 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 23 Jun 2015 07:27:54 posted by Tamara Blasco
Please note that I couldn't reproduce this issue. Following the steps you mentioned as well as what you did in the attachment, I still get EasyList and Adblock Warning Removal List when accessing Filter preferences after installing.

Could you please try waiting to open Filter preferences after installing for a little bit? Let us know if that makes a difference.

Thanks

2 - 23 Jun 2015 08:38:13 posted by Rajeswari Vemuri
After deleting "adblock plus" user files folder, without closing the browser if ABP is re-installed, this issue occurs. May be this is invalid procedure.

3 - 25 Jun 2015 12:02:44 posted by Philip Hill
Your video actually show you closing Firefox. Can you still reproduce this issue with closing Firefox in between?

4 - 25 Jun 2015 12:04:11 posted by Philip Hill
See above.

5 - 25 Jun 2015 12:45:17 posted by Rajeswari Vemuri
It is reproducible with the version 2.6.9.3935. It is not reproducible with latest versions.

comment:2 Changed 4 years ago by Shikitita

  • Description modified (diff)

This seems to be an issue occurring only in old builds like 2.6.9.3935 or 2.6.9.3937, but not in the latest one (2.6.9.3955). Therefore I will set it as "worksforme".

comment:3 Changed 4 years ago by Shikitita

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.