Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2733 closed defect (worksforme)

ABP Chrome does not display received notifications

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: greiner Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Ross Verified working: no
Review URL(s):

Description

Environment

ABP 1.9.0.1458
Chrome 43.0.2357.130 / Windows 8.1 x64

How to reproduce

  1. Set up a valid notification on the server.
  2. Un-install/Re-install the ABP for Chrome development build.
  3. Restart Chrome.
  4. Wait one minute for notifications to be requested.
  5. Confirm the response contained a notification.
  6. Observe ABP for Chrome never displays the notification.

Observed behaviour

The notification is never displayed.

Expected behaviour

The notification should be displayed.

Change History (5)

comment:1 Changed 4 years ago by greiner

  • Summary changed from ABP Chrome does not display receieved notifications to ABP Chrome does not display received notifications

Cannot reproduce this issue with the following setups:

Adblock Plus 1.9.0.1458
Chrome 43.0.2357.130 (64-bit)
Ubuntu 14.04

Adblock Plus 1.9.0.1458
Chrome 43.0.2357.130 m
Windows 8.1

notification.json:

{
  "notifications": [
    {
      "id": 1,
      "type": "information",
      "message": "This is a test!"
    }
  ],
  "version": "201506291240"
}

Note that "information"-type messages don't trigger a desktop notification to be shown. They only cause the toolbar icon to animate and the message to be shown within in the icon popup.

comment:2 Changed 4 years ago by greiner

  • Cc greiner added

comment:3 follow-up: Changed 4 years ago by Ross

  • Resolution set to worksforme
  • Status changed from new to closed
  • Tester set to Ross

Thank you for checking. Works as described.

For my future reference:

  • "information" = Animate icon. Displayed in popup.
  • "critical" = Displayed as Chrome notification.

ABP 1.9.0.1458
Chrome 43.0.2357.130 / Windows 8. x64

comment:4 in reply to: ↑ 3 Changed 4 years ago by greiner

Replying to Ross:

For my future reference:

  • "information" = Animate icon. Displayed in popup.
  • "critical" = Displayed as Chrome notification.

Actually, it's a bit more complicated and unfortunately, we don't have a proper documentation for that yet so here's the gist of it:

  • critical
    • animate icon with "!"
    • show in popup
    • show desktop notification
  • information
    • animate icon with "?"
    • show in popup
  • question
    • show desktop notification

Note that a desktop notification can be all sorts of things, depending on the capabilities of the platform (e.g. Chrome notification, window.confirm(), XUL panel).

comment:5 Changed 4 years ago by Ross

Useful thank you! Will try to include it in the testing notes.

Note: See TracTickets for help on using tickets.