Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2742 closed defect (invalid)

Block element should not block logo for websites like facebook and yahoo.

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Shikitita, sebastian Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-185

Environment

Windows + 7 64bit + Chrome + English
ABP version 1.8.12.1425

How to reproduce

  1. Install ABP.
  2. Open www.google.com
  3. Click on ABP icon.
  4. Click on Block element.
  5. Try to block the google logo.
  6. You can see that google logo cannot be blocked.
  7. Now open www.yahoo.com or www.fb.com
  8. Try to block yahoo or facebook logo.
  9. You can see that logo can be blocked.

Observed behaviour

Logo for websites like facebook or yahoo are blocked using block element.

Expected behaviour

Logo for websites like facebook or yahoo should not be blocked using block element as logo for google cannot be blocked.

Attachments (1)

6357_1431760225_Logoblock.wmv (1.7 MB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by passbrains

1 - 22 May 2015 09:01:09 posted by Timo Scherf
Reproduced as described,
please notice that in comparsion in firefox everything is working as expected.

Yahoo icon seems to be an image:

Yahoo

Google icon seems to be part of the background theme:

Deutschland

comment:2 Changed 4 years ago by Shikitita

  • Description modified (diff)
  • Resolution set to invalid
  • Status changed from new to closed

If this has not been done yet and it is possible, would there be any way the option to block an element could be removed for Google's website in this case? If it is whitelisted, it would be better not to display that function in order not to mislead the user as it will not work.

comment:3 Changed 4 years ago by sebastian

Yes, this element cannot be blocked because it is whitelisted. Hence it cannot be selected. Though if there would be any ancestor that can be blocked, it would be selected instead. But this isn't the case here.

What you experience here is the same behavior you get with any element that cannot be blocked for whatever reason. However, if the whole page is whitelisted the "Block Element" option is already removed, but this isn't the case here either.

comment:4 Changed 4 years ago by sebastian

  • Cc Shikitita sebastian added
Note: See TracTickets for help on using tickets.