Opened 4 years ago

Closed 4 years ago

#2748 closed defect (duplicate)

abp: links don't work with E10S enabled

Reported by: mapx Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: trev, greiner, prr Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

windows 7
firefox dev edition 41.0a2 (2015-07-03)
ABP 2.6.9.3957

How to reproduce

go to https://adblockplus.org/en/subscriptions
subscribe fanboy's annoyances (or other list)

Observed behaviour

error:

The address wasn't understood

Firefox doesn't know how to open this address, because one of the following protocols (abp) isn't associated with any program or is not allowed in this context.

You might need to install other software to open this address.

Expected behaviour

the list should be correctly added to ABP

thread on forum
https://adblockplus.org/forum/viewtopic.php?f=1&t=36654

Change History (7)

comment:1 Changed 4 years ago by mapx

  • Cc trev greiner added
  • Summary changed from Firefox Developer Edition does not recognize abp protocol to Firefox Developer Edition (41.0a2) does not recognize abp protocol (ABP 2.6.9.3957)

comment:2 Changed 4 years ago by mapx

  • Cc prr added

comment:3 Changed 4 years ago by prr

If you want me to troubleshoot anything, I have FDE x64 on Windows. I can try links with e10s enabled or disabled.

comment:4 Changed 4 years ago by mapx

  • Description modified (diff)

comment:5 Changed 4 years ago by trev

  • Priority changed from Unknown to P3
  • Ready set

Yes, this is caused by e10s, see also https://bugzilla.mozilla.org/show_bug.cgi?id=1151335. The problem here is that mouse events aren't reaching the chrome process. The solution would be handling clicks on abp: links in a frame script.

comment:6 Changed 4 years ago by trev

  • Summary changed from Firefox Developer Edition (41.0a2) does not recognize abp protocol (ABP 2.6.9.3957) to abp: links don't work with E10S enabled

comment:7 Changed 4 years ago by greiner

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1730

Note: See TracTickets for help on using tickets.