Opened 6 years ago

Closed 5 years ago

#278 closed change (duplicate)

Add a pre-configurable option to disable the first run page in Chrome

Reported by: fhd Assignee:
Priority: P3 Milestone:
Module: Platform Keywords: growth, large-scale-deployments
Cc: greiner, trev, mapx, sebastian, simona Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Background

There are some large installations of ABP, which are sometimes in an environment where the browser profile is reset whenever the user logs out.

What to change

Add a pre-configurable property (as implemented by #1487 and #1488) to skip the first run page.

Change History (17)

comment:1 Changed 6 years ago by fhd

  • Priority changed from Unknown to P4
  • Ready set

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 6 years ago by mapx

requested also for firefox ==> https://issues.adblockplus.org/ticket/206

comment:4 follow-up: Changed 6 years ago by trev

  • Cc trev added

It might make sense to change the prefs.js implementation for Chrome to use the storage API in general. We cache prefs anyway so we should be able to deal with asynchronous APIs here. Note that we would need to change required Chrome version to at least 20 - given that Yandex Browser is based on current Chrome versions now this seems fine however.

comment:5 Changed 5 years ago by treed873

Hello,

Is this still on the docket to be changed/fixed? The ability to turn off the first run page would be greatly beneficial in large corporate environments. Thanks for all of your hard work!

comment:6 follow-up: Changed 5 years ago by philll

  • Platform set to Unknown

Hi,

yes, this is planned to get done within other improvements for a large scale deployment, see #542. Until this is done, you can find some support at https://adblockplus.org/forum/viewforum.php?f=21

comment:7 Changed 5 years ago by mapx

  • Cc mapx added; smultron45@… removed

comment:8 Changed 5 years ago by sebastian

  • Blocked By 1487 added

comment:9 in reply to: ↑ 4 Changed 5 years ago by sebastian

  • Cc sebastian added

Replying to trev:

It might make sense to change the prefs.js implementation for Chrome to use the storage API in general.

I like the idea, since this is how Chrome extensions are supposed to store persistent properties nowadays. But on the other hand, on Safari we anyway have to store these data in a different way. So this might just over-complicate things.

We cache prefs anyway so we should be able to deal with asynchronous APIs here.

We still won't have access to the prefs during extension startup. But we have to deal with that anyway, also if only using the Managed Storage API for the pre-configured settings.

Note that we would need to change required Chrome version to at least 20 - given that Yandex Browser is based on current Chrome versions now this seems fine however.

We require Chrome 28+ meanwhile. So this wouldn't be an issue anymore.

Last edited 5 years ago by sebastian (previous) (diff)

comment:10 in reply to: ↑ 6 Changed 5 years ago by sebastian

  • Blocked By 1488 added; 1487 removed
  • Description modified (diff)

Replying to fhd:

It would be nice to have an ​extension option that disables the first run page, since extension options can be imported.

Some prior discussion on this: ​https://twitter.com/refLyeART/status/374543864918732800

That is not possible, neither can we read a local file as you(?) confirmed on Twitter. But fortunately the Managed Storage API were added meanwhile for this purpose, see #1488.

comment:11 Changed 5 years ago by sebastian

  • Blocking 542 added

comment:12 Changed 5 years ago by sebastian

  • Priority changed from P4 to P3

comment:13 Changed 5 years ago by sebastian

  • Summary changed from [Chrome] Make it possible to disable the first run page for large installations to Add a pre-configurable option to disable the first run page in Chrome

comment:14 Changed 5 years ago by simona

  • Keywords growth added

comment:15 Changed 5 years ago by simona

  • Cc simona added

comment:16 Changed 5 years ago by simona

  • Keywords large-scale-deployments added

comment:17 Changed 5 years ago by sebastian

  • Blocked By 1488 removed
  • Blocking 542 removed
  • Resolution set to duplicate
  • Status changed from new to closed

This issue has been merged into #1488.

Note: See TracTickets for help on using tickets.