Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#2789 closed defect (fixed)

[Adblock Browser for iOS] Dates are not synchronised properly in the History

Reported by: Shikitita Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: pavelz, jand, vojtab, Shikitita Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Platform: iPhone 5s
Operating System: iOS 8.4
Browser: Adblock Browser 0.9.0

How to reproduce

  1. Open Adblock Browser on a New Tab if possible (this is done by closing the browser while displaying a new tab)
  2. In the Dashboard, swipe towards the left in order to display the History (make sure the browser’s History was not deleted so that there is some data there)
  3. Observe the date shown as Today
  4. Open now a new tab by tapping on the icon at the bottom right corner of the screen and then on the cross
  5. Surf through different websites in order to add more data to the History
  6. Access the History again and look at the date(s) shown as Today

Observed behaviour

The History does not synchronise the day with when the websites were visited (Today or Yesterday).

Expected behaviour

The references Today and Yesterday in the History should be synchronised accordingly with when the websites were visited.

Attachments (4)

History_Date_01.jpg (237.0 KB) - added by Shikitita 4 years ago.
History_Date_02.jpg (244.3 KB) - added by Shikitita 4 years ago.
History_Date_03.jpg (245.7 KB) - added by Shikitita 4 years ago.
History_Date_04.jpg (216.3 KB) - added by Shikitita 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by Shikitita

Changed 4 years ago by Shikitita

Changed 4 years ago by Shikitita

Changed 4 years ago by Shikitita

comment:1 Changed 4 years ago by Shikitita

Please note that I've been able to reproduce this for three days (since Monday the 13th) and, as you can see in the attached screenshots, I have currently four dates displayed as Today in my History. This happened after doing steps 4 and 5 and then checking the History.

What is more, the date shown in the screenshot attachment:History_Date_04.jpg as “Today Thursday 9 July 2015”, was displayed correctly as “09/07/15 Thursday 9 July 2015” before I proceeded to do steps 4 and 5.

Please also note that screenshot attachment:History_Date_03.jpg is showing the websites that can be also visible in attachment:History_Date_04.jpg. This is to prove that these screenshots were all taken the same day.

comment:2 Changed 4 years ago by Shikitita

  • Cc Shikitita added

comment:3 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 years ago by philll

  • Sensitive unset
Note: See TracTickets for help on using tickets.