Opened 4 years ago

Closed 4 years ago

#2803 closed defect (invalid)

Adblock plus controls all gone or non-functional.

Reported by: Hallfaer Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Linux 4.0.0-2-amd64 #1 SMP Debian 4.0.8-1 (2015-07-11) x86_64 GNU/Linux
Mozilla Firefox 42.0a1 (2015-07-18)
Adblock Plus 2.6.9.1-signed

Filter list cannot be verified due to the bug. Presumably the most common list for Dutch Adblock users.

How to reproduce

Unknown.
Start of the bug is unknown, as the filter functionality itself continues to function perfectly. However all means to control the addon are inaccessible or non-functional. I normally do not have the Adblock Plus button visible in any status bar, instead I have it in the menu.

Observed behaviour

No Adblock buttons are present in toolbars, or in the menu. No “Adblock Plus” buttons seem to be registered with the user interface management system. Additionally in the Addons Manager on Adblock Plus' page, the “Filter preferences” button can be clicked, but nothing happens. The checkboxes can be checked and unchecked but don't affect the addon's behaviour. E.g. when “Disable everywhere” is checked, all ads on the web are still hidden.

Expected behaviour

Clearly the addon has a normally functional UI. For some reason it seems to be malfunctioning. I'm not familiar with the code base, but I assume it uses MVC, and this suggests that something basic in the View code is not working as intended. I actually found out that the addon was malfunctioning because I wanted to allow ads on a certain site, and found that I could not find any Adblock Plus buttons.

Change History (4)

comment:2 Changed 4 years ago by mapx

  • Cc mapx added

comment:3 Changed 4 years ago by Hallfaer

Ah, I can confirm that it's solved in the dev build.
Sorry, I should've tried that before I created the ticket.

comment:4 Changed 4 years ago by mapx

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.