Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2805 closed defect (fixed)

Regression: Error in Firefox first-run page: filterValidation module doesn't exist

Reported by: greiner Assignee: greiner
Priority: P1 Milestone:
Module: User-Interface Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29322723/

Description

Environment

Firefox 42.0a1
Adblock Plus 2.6.9.3961 (with adblockplusui revision 20)

How to reproduce

  1. Open first-run page
  2. Open browser console

Observed behavior

The following error can be seen:

1437421089832 addons.xpi  WARN  Exception running bootstrap method startup on {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}: Error opening input stream (invalid filename?): jar:file:///home/thomas/.mozilla/firefox/njib3tdv.Default%20User/extensions/%7Bd10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d%7D.xpi!/lib/filterValidation.js

Expected behavior

No such error is shown.

Background

This is a regression from #2376 which occurs because the "filterValidation" module only exists in the context of adblockpluschrome. For now it should be sufficient to move the require() call to the respective message responses since they'll initially only be used in that context.

Later on we'll need an implementation or an abstraction of that module in the ext-API.

Change History (3)

comment:1 Changed 5 years ago by greiner

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 5 years ago by trev

  • Milestone Adblock-Plus-2.6.10-for-Firefox deleted

Removed milestone - this change wasn't imported into Adblock Plus for Firefox directly but as part of the dependency update in #2808.

comment:3 Changed 5 years ago by greiner

  • Review URL(s) modified (diff)
Note: See TracTickets for help on using tickets.