Opened 4 years ago

Closed 4 years ago

#2829 closed defect (fixed)

[Adblock Browser for iOS] [More Blocking Options] Options disable themselves

Reported by: passbrains Assignee:
Priority: P3 Milestone: Adblock-Browser-for-iOS-1.2.0
Module: Adblock-Browser-for-iOS Keywords: salsita, v
Cc: jand, pavelz, vojtab, Shikitita, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by Shikitita)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AKI-30

Environment

Apple + iPhone 4S + iOS 8.4

How to reproduce

  1. Run the app
  2. Go to settings
  3. Select Adblock Plus
  4. Select More Blocking Options
  5. Select all four options (Disable Tracking, Disable Malware Domains, Disable Social media Buttons, Disable Anti-Ad blocking messages) (On state)
  6. Go back to the previous screen and select again More Blocking Options

Observed behaviour

All four options are deselected (OFF state)

Expected behaviour

All four options should be selected (ON state)

Attachments (3)

12221_1437427867_IMG_49361.PNG (66.3 KB) - added by passbrains 4 years ago.
12221_1437427867_IMG_49371.PNG (58.3 KB) - added by passbrains 4 years ago.
12221_1437427868_IMG_49381.PNG (62.8 KB) - added by passbrains 4 years ago.

Download all attachments as: .zip

Change History (11)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by Shikitita

  • Description modified (diff)
  • Summary changed from More blocking options deselects itself to [Adblock Browser for iOS] [More Blocking Options] Options disable themselves

comment:2 Changed 4 years ago by Shikitita

After further testing, the issue keeps occurring under the following scenarios:

  • when having 15 tabs open or more, each with a different website (build 0.12.0 (DEV-352)
  • when having only one empty tab open but subscribing to the different filter lists in Settings » Adblock Plus » Ad blocking (this one being so far the most reliable way to reproduce it)

First scenario:

  1. Make sure to have around 15 tabs open or more with a website each. (In order to do this, tap on the icon at the bottom right corner of the screen and then on the cross also at the bottom right corner. Tap on “Search or enter website name” at the top of the screen in order to enter a URL. Repeat this process with a different website for each tab for 14 more times.)
  2. Access the settings by tapping on the Adblock Browser icon in the middle at the bottom of the screen and then on "Settings"
  3. Tap on Adblock Plus » More Blocking Options
  4. Enable two different options
  5. At the top left of the screen tap on Adblock Plus » Back and then “Done” at the top right of the screen
  6. Access the settings again by following step 2 and tap on Adblock Plus » More Blocking Options

The different options should be reverted back to the disabled state. However, going only one step back (in this case “Adblock Plus”) and then accessing “More Blocking Options” again, shows the options displayed as they were left before, two enabled and two disabled.

Second scenario:

  1. Install Adblock Browser and open it
  2. Access the settings by tapping on the Adblock Browser icon in the middle at the bottom of the screen and then on “Settings”
  3. Tap on Adblock Plus » More Blocking Options
  4. Enable the four different options displayed on the screen by tapping on the toggle switch on the right side next to each option
  5. Go back to “Adblock Plus” by tapping on “Adblock Plus” at the top left of the screen
  6. Tap now on “Ad blocking”
  7. Subscribe to each single filter list by tapping on the toggle switch on the right of each filter list
  8. Tap on “Adblock Plus” at the top left of the screen
  9. Tap on “More Blocking Options”

The different options in “More Blocking Options” enabled before subscribing to the filter lists should be displayed now as disabled.

Note: this was reproduced in builds 0.12.0 stage-349 (core 1.2.17) and 0.12.0 (DEV-353).

comment:3 Changed 4 years ago by Shikitita

  • Cc Shikitita added

comment:4 Changed 4 years ago by philll

  • Sensitive unset

comment:5 Changed 4 years ago by mario

  • Cc mario added
  • Component changed from Unknown to Adblock-Browser-for-iOS
  • Priority changed from Unknown to P3

Priority set to P3 as this only seems to occur on iPhone 4S (and below?) and is rather difficult to reproduce.

comment:6 Changed 4 years ago by mario

  • Keywords salsita added

comment:7 Changed 4 years ago by pavelz

  • Keywords v added

comment:8 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.2.0
  • Ready set
  • Resolution set to fixed
  • Status changed from new to closed

We weren't able to reproduce this issue reliably. However it "should" be solved due to refactoring of corresponding components.
Please keep this in mind during the next QA iteration and re-open this issue if necessary.

The refactoring happened for 1.2.0 which is why I'll assign them to that milestone even though it has been closed already.

Note: See TracTickets for help on using tickets.