Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#2835 closed defect (fixed)

Find alternative setup for sharing data with VirtualBox

Reported by: matze Assignee: poz2k4444
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: fred, fhd Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29363649/

Description

The shared file-system built into VirtualBox sometimes does not recognize updates on the host side properly:

vagrant@filtermaster1:~$ ls -la /etc/puppet/infrastructure/modules/private/hiera/roles/
ls: cannot access /etc/puppet/infrastructure/modules/private/hiera/roles/filtermasterserver.yaml: No such file or directory
total 8
drwxr-xr-x 1 vagrant vagrant  92 Jul 29 15:19 .
drwxr-xr-x 1 vagrant vagrant  51 Jul 29 14:55 ..
-rw-r--r-- 1 vagrant vagrant 351 Jun 15 12:57 codereviewserver.yaml
?????????? ? ?       ?         ?            ? filtermasterserver.yaml
-rw-r--r-- 1 vagrant vagrant 434 Jun  3 07:40 monitoringserver.yaml

While this is actually a known issue with VirtualBox (Vagrant recommends using NFS instead, but who wants to operate an NFS server on the own laptop or workstation?) that happens just a few times per week (when working with that stuff every day), it's always a very time consuming issue - because it's usually not obvious and one wastes hours debugging senseless results.

However, we may be able to reduce the probability of such issues by slightly adjusting our setup, e.g. trying some alternatives for this part of the Vagrantfile:

# The repository location in the production system's puppet master          
config.vm.synced_folder ".", "/etc/puppet/infrastructure" 

Last but not least; the above example has occurred during #2814 and caused us not realizing a regression (or rather us not realizing the regression during testing), which actually got pushed..

Change History (3)

comment:1 Changed 3 years ago by paco

  • Owner set to poz2k4444
  • Review URL(s) modified (diff)

comment:2 Changed 3 years ago by paco

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
Issue 2835 - Use rsync for folder synchronization in Vagrant

Note: See TracTickets for help on using tickets.