Opened 4 years ago

Closed 4 years ago

#2837 closed defect (fixed)

App crashes after a few minutes of browsing on site where adds are blocked

Reported by: passbrains Assignee:
Priority: P3 Milestone: Adblock-Browser-for-iOS-1.2.0
Module: Adblock-Browser-for-iOS Keywords: salsita, v
Cc: jand, pavelz, vojtab, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mario)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AKI-32

Environment

Apple + iPhone 4 CDMA + iOS 7.1.2

How to reproduce

  1. install and open app
  2. navigate to "net.hr"
  3. open various articles and go back to home page (browse the site)

Observed behaviour

App crashes after 4-5 minutes of browsing site

(In my settings>about version is v0.11.0 stage-322, but latest i can select in dashboard it is 0.10.0, so i have selected n/a)

Expected behaviour

App should not crash

Attachments (5)

Change History (10)

Changed 4 years ago by passbrains

Changed 4 years ago by passbrains

comment:1 Changed 4 years ago by philll

  • Sensitive unset

comment:2 Changed 4 years ago by mario

  • Cc mario added
  • Component changed from Unknown to Adblock-Browser-for-iOS
  • Description modified (diff)

comment:3 Changed 4 years ago by mario

  • Keywords salsita added

comment:4 Changed 4 years ago by pavelz

  • Keywords v added

comment:5 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-1.2.0
  • Priority changed from Unknown to P3
  • Ready set
  • Resolution set to fixed
  • Status changed from new to closed

We weren't able to reproduce this issue reliably. However it "should" be solved due to refactoring of corresponding components.
Please keep this in mind during the next QA iteration and re-open this issue if necessary.

The refactoring happened for 1.2.0 which is why I'll assign them to that milestone even though it has been closed already.

Note: See TracTickets for help on using tickets.