Opened 4 years ago

Closed 4 years ago

#2849 closed defect (fixed)

Installing Trac plugins fails when provisioning new issue server

Reported by: matze Assignee: matze
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: fred Blocked By:
Blocking: #2780, #2782, #2783 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29323178

Description

An error message like the one below is the result of attempting to install any Trac plugin via Puppet:

==> issues1: err: /Stage[main]/Trac/Exec[install_MasterTickets]/returns: change from notrun to 0 failed: pip install svn+http://trac-hacks.org/svn/masterticketsplugin/trunk/ returned 1 instead of one of [0] at /tmp/vagrant-puppet-2/modules-0/trac/manifests/init.pp:86

Change History (2)

comment:1 Changed 4 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

It turns out that trac-hacks.org now accepts HTTPS requests only. That's nice.

comment:2 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.