Opened 4 years ago

Closed 3 years ago

Last modified 3 years ago

#2850 closed defect (fixed)

Two Firefox windows open when clicking on an external link

Reported by: enviroplanter Assignee: trev
Priority: P2 Milestone:
Module: Automation Keywords:
Cc: trev, greiner, mapx, fhd Blocked By:
Blocking: #2444 Platform: Firefox
Ready: yes Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29337900/

Description (last modified by greiner)

Environment

Adblock Plus 2.6.10, Firefox 39.0, OS X 10.10.4

How to reproduce

  • Quit Firefox if necessary
  • Click on an external link (e.g. from Apple Mail or Apple Contacts)

Observed behaviour

2 windows open--one is the link and the other is the Firefox home page. Removing Adblock Plus corrects the problem. Problem just started with 2.6.10.

Expected behaviour

Only the link window is expected.

forum thread: https://adblockplus.org/forum/viewtopic.php?f=1&t=39748

Change History (15)

comment:1 Changed 4 years ago by enviroplanter

Note: This happens when Firefox is not open prior to clicking on the external link.

comment:2 Changed 4 years ago by mapx

  • Cc trev greiner mapx added

comment:3 Changed 4 years ago by mapx

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Description modified (diff)

comment:4 Changed 4 years ago by greiner

  • Description modified (diff)

I was able to reproduce this issue with the environment below but no success on Windows 8.1 or Ubuntu 14.04.

Adblock Plus 2.6.10
Firefox 39
OSX 10.8 and 10.10

I also noticed that when opening Firefox through the command line using open https://www.adblockplus.org it would open the webpage only if Firefox was still open and a single empty window otherwise.

comment:5 Changed 4 years ago by greiner

  • Cc fhd added

The last good build was 2.6.9.3933 so this regression appears to have been introduced by #2438.

comment:6 Changed 3 years ago by jshrek

I can confirm this issue still occurs on OSX 10.11.3 with Firefox 44.0.2 and AdblockPlus 2.7.2

comment:7 Changed 3 years ago by trev

  • Priority changed from Unknown to P2
  • Ready set

Yes, I can see this as well. I'm running the following command:

open -a /Applications/FirefoxNightly.app http://mail.ru/

This opens two windows as reported. However, I had to disable lots of extensions in order to have this fixed - e.g. Element Hiding Helper triggers the same issue.

I'm pretty certain that the problem here is a timing change due to prefs.js producing a synchronous XMLHttpRequest at startup.

comment:8 Changed 3 years ago by trev

  • Blocking 2444 added

comment:9 Changed 3 years ago by trev

  • Component changed from Adblock-Plus-for-Firefox to Build-and-Release-Tools
  • Owner set to trev

comment:10 Changed 3 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:11 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/buildtools/rev/c92cc4e4a338

comment:12 Changed 3 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

Fixed: https://hg.adblockplus.org/buildtools/rev/c92cc4e4a338

I'll create additional issues on getting this into all relevant extensions via build tools update.

comment:13 Changed 3 years ago by abpbot

A commit referencing this issue has landed:
https://hg.adblockplus.org/buildtools/rev/c92cc4e4a338

comment:14 Changed 3 years ago by trev

I created #3743, #3744, #3746, #3747, #3748 on dependency updates for all the relevant extensions.

comment:15 Changed 3 years ago by Ross

  • Tester changed from Unknown to Ross
  • Verified working set

ABP 2.7.2.4166
Firefox 38 / 44 / OS X 10.11

Note: See TracTickets for help on using tickets.