Opened 4 years ago

Closed 2 years ago

#2852 closed defect (rejected)

Adblock Browser does not support Intel hardware / always crashes on launch

Reported by: Ross Assignee:
Priority: Unknown Milestone:
Module: Adblock-Browser-for-Android Keywords:
Cc: fhd, philll Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Ross Verified working: no
Review URL(s):

Description

Environment

Adblock Browser 1.0.0.20150520125137
Asus TransformerPad TF103C (Intel) / Android 4.4+.

How to reproduce

  1. Install Adblock Browser.
  2. Attempt to run Adblock Browser.
  3. Observe it crashes upon launch.

Observed behaviour

Adblock browser always crashes upon launch. This appears to be because we do not yet support Android devices running on Intel hardware.

Expected behaviour

Possible fixes could be:

  1. Support Intel hardware.
  2. Refuse to install the app in the first place if on Intel hardware until supported.
  3. Show a message saying "This device is not supported" instead of just crashing.

Change History (2)

comment:1 Changed 2 years ago by diegocarloslima

This was only possible if the user downloaded himself the .apk and manually installed it. But if I'm not mistaken, starting from Lollipop, this isn't possible anymore, the Package installer will fail with an incompatible message. Also, with #4677, we can now build for Intel devices. Since this isn't a concern anymore, I'm closing this ticket.

comment:2 Changed 2 years ago by diegocarloslima

  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.