Opened 2 years ago

Closed 9 months ago

Last modified 5 months ago

#2853 closed defect (fixed)

Settings changes are sometimes not saved if the user quits the app

Reported by: Ross Assignee: diegocarloslima
Priority: Unknown Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: philll, fhd Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29350065/

Description (last modified by Ross)

Environment

Adblock Browser 1.0.0.20150520125137
LG Nexus 4 E960 / Android 5.1.1 (TestObject Device)

How to reproduce

  1. Start Adblock Browser.
  2. Select [Settings] > [Adblocking] > [Acceptable Ads].
  3. Uncheck the [Allow some ...] checkbox.
  4. Press [Back] in the header once, wait ~3-5 seconds.
  5. Press the hardware [Menu/Apps] key.
  6. Swipe the browser away to kill it.
  7. Restart the browser.
  8. Select [Settings] > [Adblocking] > [Acceptable Ads].
  9. Observe the [Allow some ...] checkbox is checked again (Unexcepted - Was unchecked at Step 3).
  10. Uncheck the [Allow some ...] checkbox.
  11. Back out of [Settings] to the browser.
  12. Wait a few seconds (5-10).
  13. Press the hardware [Menu/Apps] key.
  14. Swipe the browser away to kill it.
  15. Restart the browser.
  16. Select [Settings] > [Adblocking] > [Acceptable Ads].
  17. Observe the [Allow some ...] checkbox is checked (as expected).
  18. Try these steps again, changing the setting and then quitting at different times, then checking if the setting was saved.

Observed behaviour

Depending on when the user suspends, quits or kills the browser, the Acceptable Ads setting (and possibly other settings) are not saved and the value last selected by the user is not correctly restored on the next run.

Expected behaviour

The value last selected by user should be correctly saved and restored on the next run, regardless (sort of) on how they quit or leave the app.

Attachments (1)

AcceptableAdsReset.mp4 (3.6 MB) - added by Ross 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by Ross

comment:1 Changed 2 years ago by Ross

  • Description modified (diff)

So I know the initial reaction is "Well if you kill the browser before it saves the setting, of course the setting isn't saved" but it gives a terrible (imo) user experience and is really confusing. Sometimes the setting IS saved if you quit at a certain point. Sometimes the setting is NOT saved if you quit at a certain point.

How should/does saving the settings work? I thought it might be triggered either on each settings change or when the settings menu itself is left? Or that it is async? If so how long should it take?

The video I've attached shows an example of the issue (although it does not exactly match the steps). I could not reproduce this on my actual device, but can on several of the TestObject devices.

Last edited 2 years ago by Ross (previous) (diff)

comment:2 Changed 15 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:3 Changed 15 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 11 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next

comment:6 Changed 9 months ago by diegocarloslima

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 5 months ago by scheer

  • Tester changed from Ross to Scheer
  • Verified working set
  • In all of the above-given examples along with extra case testing here, I was unable to reproduce that the settings are no longer saved anymore. Each time I de-selected an option or setting, close the browser, waited, re-opened etc. the setting was always kept.

ABB adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Note: See TracTickets for help on using tickets.