Opened 4 years ago

Closed 3 years ago

#2875 closed defect (worksforme)

ModPagespeed defer_javascript issue with active ABP

Reported by: Rotate Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, trev, mapx, arthur, kzar Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by mapx)

Environment

Win 7, Chrome latest, Safari latest.

Observed behaviour

When I enable "ModPagespeedEnableFilters defer_javascript ", the page is going really fast.
I win at the Page Speed ​​Insights Score added +30 points .
Unfortunately, there is then a few problems :

Chrome with active Adblocker plugin didn't render the page completely. It hangs in process ("waiting for Adblocker Plus" in the status bar.
In FireFox the problem doesn't occur with active AdBlocker.

With deactivated Adblocker everything is fine in Chrome and FF.
In Safari on iOS (eg. iPhone) the page will depend also.

Expected behaviour

Please take a look at this article-site: http://www.dance-charts.de/201508075831/felix-jaehn-feat-polina-book-of-love
Soundcloud-player, disqus and several other elements won't be loaded with active AdBlocker Plus in Chrome.

Change History (20)

comment:1 Changed 4 years ago by mapx

  • Cc sebastian trev mapx arthur added
  • Component changed from Unknown to Platform

comment:3 Changed 4 years ago by Rotate

At the moment "ModPagespeed defer_javascript" is deactivated at the article-site (see link above).

comment:4 follow-up: Changed 4 years ago by mapx

probably you should prepare a test page where ModPagespeed defer_javascript is always enabled

comment:5 in reply to: ↑ 4 Changed 4 years ago by Rotate

Replying to mapx:

probably you should prepare a test page where ModPagespeed defer_javascript is always enabled

Coming soon...

comment:6 Changed 4 years ago by mapx

  • Description modified (diff)

comment:7 Changed 4 years ago by Rotate

Please check this test-page:

http://www.dance-charts.de/tippspiel

comment:8 Changed 4 years ago by mapx

the test page is ok in firefox
it seems to be ok in chrome only adding this exception

@@||ad.yieldlab.net$domain=dance-charts.de

comment:10 Changed 4 years ago by Rotate

Unfortunately not. No change with the updated whitelist. Just checked.
The demo-page is not active at the moment. Too much bugs. I can reacitvate if you want for a certain time.

https://picload.org/image/iwggcld/adblocker.jpg

comment:11 Changed 4 years ago by arthur

Yes, please re-activate it.

comment:12 Changed 4 years ago by Rotate

It's active now on this site only: www.dance-charts.de/tippspiel

comment:13 Changed 4 years ago by Rotate

Any new insights?

comment:14 Changed 4 years ago by kzar

  • Cc kzar added

Hi Rotate, please can you update the ticket description with a concrete list of steps I should take to reproduce, with expected vs observed outcomes? I can't reproduce this as described but I don't want to reject the issue before I properly understand.

comment:15 Changed 4 years ago by kzar

  • Resolution set to worksforme
  • Status changed from new to closed

Closing this for now as it has been about a month since I asked for help reproducing the issue.

comment:16 Changed 3 years ago by Rotate

  • Resolution worksforme deleted
  • Status changed from closed to reopened

okay. Next try. Still the same problem:
Website doesn't render completly / breaks with active ABP in Chrome. Without there is no problem.
In Firefox it works fine with active ABP.

Examples:
www.dance-charts.de
www.dance-charts.de/tippspiel
www.dance-charts.de/201512306543/guns-n-roses-comeback-beim-coachella-festival-2016

Menu-navigation drop downs doesn't work or some elements in the right sidebar breaks.
"ModPagespeed defer_javascript" is active now. We should solve this problem.

comment:17 Changed 3 years ago by mapx

@@||dance-charts.de^$genericblock
||tpc.googlesyndication.com/pagead/imgad$domain=dance-charts.de
||adclick.g.doubleclick.net^$popup,domain=dance-charts.de
||dance-charts.de/images/banners/*$domain=dance-charts.de
dance-charts.de##.advert
Last edited 3 years ago by mapx (previous) (diff)

comment:18 Changed 3 years ago by Rotate

Thanks. Seems to be working here.

Last edited 3 years ago by Rotate (previous) (diff)

comment:19 Changed 3 years ago by arthur

I couldn't encounter any issues on the provided links.

comment:20 Changed 3 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from reopened to closed

As far as I understand, ModPageSpeed is an nginx/Apache module that manipulates your web content to optimize performance. There is a setting defer_javascript which if enabled, causes the HTML to be rewritten in a way that scripts are loaded after the page finished loading.

According to OP, on their website, some third-party widgets (e.g. SoundClous, Disqus) doesn't load if using Adblock Plus and if defer_javascript is enabled. With the links provided above I couldn't reproduce that, however.

Since, others apparently couldn't reproduce the issue either with the information provided, I am closing this issue now. Feel free to reopen if it happens again, but provide exact steps to reproduce, the exact version of Chrome and Adblock Plus you are using, and your Adblock Plus settings.

Note: See TracTickets for help on using tickets.