Opened 4 years ago

Closed 4 years ago

#2894 closed defect (fixed)

'archive.org/web' links fail to open on rooted devices

Reported by: rjeschke Assignee: rjeschke
Priority: P2 Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29323464/

Description

Environment

all versions, rooted phones

How to reproduce

  1. Got to: http://web.archive.org/*/https://adblockplus.org

Observed behaviour

404 Not found

Expected behaviour

The page should be correctly displayed

Explanation/Fix

This behaviour is caused by org.adblockplus.brazil.TransparentProxyHandler that should rewrite a path-only URL with Host: header into a fully qualified URL. It checks for the existence of :// in the URL, which triggers in the above example and which then does not rewrite the URL in the correct way.

Change History (2)

comment:1 Changed 4 years ago by rjeschke

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by rjeschke

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.