Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#290 closed defect (fixed)

[seamonkey] blockable items list persists tab changes

Reported by: philll Assignee: saroyanm
Priority: P3 Milestone: Adblock-Plus-2.6.4-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6325312296058880/

Description

Environment

Seamonkey 2.25
ABP 2.5.1

How to reproduce

  1. Go to a website
  2. Open blockable items (Ctrl+Shift+V)
  3. Open a new tab (Ctrl+t) and go to another website
  4. Left-click the tab with the first website

Observed behaviour

The blockable items list still shows the items from the second tab's website.

Expected behaviour

The blockable items list should show the items from the first tab's website.

Change History (6)

comment:1 Changed 5 years ago by saroyanm

  • Owner set to saroyanm
  • Platform set to Unknown

comment:2 Changed 5 years ago by saroyanm

The issue looks caused by onLocationChange method's aFlags attribute.
While in Firefox it's implemented as optional attribute:
http://mxr.mozilla.org/mozilla-central/source/uriloader/base/nsIWebProgressListener.idl#344
In Seamonkey the implementation for the attribute is missing:
http://mxr.mozilla.org/seamonkey/source/uriloader/base/nsIWebProgressListener.idl#322

comment:3 Changed 5 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:4 Changed 5 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

Wladimir filed a bug in Seamonkey:
https://bugzilla.mozilla.org/show_bug.cgi?id=1035171

Until this is fixed we will override ignoreSameDoc parameter to false for Seamonkey.
Revision:
https://hg.adblockplus.org/adblockplus/rev/5cb1f27ffff2

comment:5 Changed 5 years ago by trev

  • Component changed from Unknown to Adblock-Plus-for-Firefox
  • Milestone set to Adblock-Plus-for-Firefox-next
  • Platform changed from Unknown to Firefox/Firefox Mobile

comment:6 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.