Opened 4 years ago

Closed 4 years ago

#2909 closed change (fixed)

Setup hg1.adblockplus.org

Reported by: matze Assignee: matze
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: fred, fhd Blocked By: #2867
Blocking: #2906, #3115 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29323724
https://codereview.adblockplus.org/29324553

Description

In order to properly integrate https://hg.adblockplus.org/ with the infrastructure module, a server for the new hgweb module needs to be setup and synchronized with the current repositories.

Change History (8)

comment:1 Changed 4 years ago by matze

  • Blocking 2908 added

comment:2 Changed 4 years ago by matze

  • Cc fhd added
  • Review URL(s) modified (diff)

The last spare-server of the smaller model has been prepared for provisioning: Operating system is installed, DNS records have been setup, RAID sync is in progress (~2h).

A new spare-server to replace this one has been ordered as well.

Note that the code-review for this very ticket here can be done already; the required changes are quite obvious and should be approved soon-ish (not at roll-out time), in order to ease testing and the application of possible subsequent patches to module hgweb (see #2867), as well as to include the host with Nagios already.

comment:3 Changed 4 years ago by matze

  • Status changed from new to reviewing

comment:4 Changed 4 years ago by matze

  • Review URL(s) modified (diff)

comment:5 Changed 4 years ago by matze

  • Blocking 2908 removed

comment:6 Changed 4 years ago by matze

  • Blocking 3115 added

comment:7 Changed 4 years ago by matze

This ticket is still open because of a bugfix in review. The issue has been discovered and hot-fixed directly after deployment a few weeks ago: Diff views did not show up properly (colors where missing) because the wrong /static/ file resources (esp. CSS files) where used.

Note that this is not a bug caused by the Puppet code in module hgweb, but by the manual setup done in the context of the GitHub synchronization, which is not integrated with Puppet yet. Thus the chosen approach simply allows for choosing the static file location via Hiera, defaulting to the package version.

Just integrating the remaining bits, on the other hand, may not even be worth the effort. At least not yet. And, as mentioned in #2867, we should consider using a more sophisticated repository server software if the current setup does not fulfill our requirements anyway.

comment:8 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.