Opened 6 years ago

Closed 5 years ago

#293 closed defect (fixed)

AdBlock button is slow to appear on toolbar after launching Firefox

Reported by: woslv Assignee: trev
Priority: P3 Milestone: Adblock-Plus-2.6.2-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: smultron45@…, trev Blocked By:
Blocking: Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5634514093080576/

Description

Environment

Windows 7 Pro x64
Firefox 28.0
AdBlock Plus 2.5.1.3791 with default filter lists

How to reproduce

Launch Firefox.

Observed behaviour

The AdBlock button takes about one second to appear on the toolbar after Firefox opens and other toolbar buttons are already present. The search box and other toolbar items suddenly adjust positions and it's distracting.

Expected behaviour

AdBlock button should appear at the same time as everything else on the toolbar.

I tried different dev builds and saw that this started in 3788 with the following change:

#3788: 2014-03-26 13:57 +0100 Wladimir Palant

Issue 196 - Filters added on first-run are being removed immediately

Change History (11)

comment:1 Changed 6 years ago by arthur

  • Component changed from Unknown to Adblock-Plus-for-Firefox

comment:2 Changed 6 years ago by mapx

  • Cc smultron45@… added

comment:3 Changed 6 years ago by greiner

I checked and actually, it started with revision 3778 and is only true for the first window. Before this change Adblock Plus startup was blocking the Firefox window from showing up. I'd assume that since the Firefox window is now showing up before Adblock Plus has finished loading, the icon is being added after the fact.

comment:4 Changed 6 years ago by woslv

I just double-checked and confirmed what I reported earlier. It's not a problem in build 3786 and happens only in 3788. I tried 3778 and it's not an issue for me there.

comment:5 Changed 6 years ago by woslv

I have felt like Firefox is starting up faster, and I'd rather it start faster without the AdBlock button than wait for AdBlock to do whatever it's doing. That said, is it not possible to get both and have the icon appear immediately before AdBlock is done initializing?

comment:6 Changed 6 years ago by woslv

If I launch Firefox with a URL, such as "firefox.exe http://www.cnn.com", Firefox opens pretty quickly but with a blank window, and then a second later the AdBlock button appears on the toolbar and the site loads at the same time. Does AdBlock prevent Firefox from doing anything while it loads?

comment:7 Changed 5 years ago by trev

  • Cc trev added

This is indeed caused by #117. However, it isn't a new issue - Adblock Plus icon was always appearing a bit after Firefox startup, the delay merely got larger now. The alternative would be showing the Adblock Plus icon immediately but keeping it dysfunctional until Adblock Plus startup actually finishes, quite an ugly solution.

comment:8 Changed 5 years ago by CoolCmd

The alternative would be showing the Adblock Plus icon immediately but keeping it dysfunctional until Adblock Plus startup actually finishes, quite an ugly solution.

This solution is not ugly. "Jumping" of ABP icon and other buttons from left of it is really annoing. ABP must first add button, and then load filters. This is right order from "user" perspective. ABP created for users, not programmers, right?

comment:9 Changed 5 years ago by trev

  • Owner set to trev
  • Priority changed from Unknown to P3
  • Ready set

comment:10 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

This change makes most of the UI code to initialize before filters are loaded. I am somewhat concerned about the consistency issues here. However, it seems mostly fine:

  • Blockable items don't need filters to work correctly.
  • Filter Preferences will open up empty but they will reinitialize once filters are loaded.
  • Disabling ABP on a site will create a filter that will be removed once the filters are loaded - not nice but not a huge either.
  • Unsetting "count filter hits" will prompt about resetting hit counts - this won't work properly if filters didn't load yet. However, having somebody go through this within seconds after startup is extremely unlikely.

comment:11 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.