Opened 4 years ago

Closed 4 years ago

#2964 closed defect (worksforme)

The menu button is clipped off the side of the screen / missing on some devices

Reported by: Ross Assignee:
Priority: P2 Milestone:
Module: Adblock-Browser-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Adblock Browser for Android
Ready: no Confidential: no
Tester: Ross Verified working: no
Review URL(s):

Description

Environment

Adblock Browser / 1.0.0.2015310815093300
Samsung I9195 Galaxy S4 mini / Android 4.4.2 / 540 x 960

How to reproduce

  1. Install Adblock Browser.
  2. Launch Adblock Browser.
  3. Observe menu button is clipped off of the side of the screen.

Observed behaviour

The menu button is clipped off of the side of the screen.

Expected behaviour

The menu button should not be completely inaccessible to the user.

Attachments (1)

AdblockBrowser-MissingMenu-SamsungGalaxyS4 mini.png (34.6 KB) - added by Ross 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by Ross

This is an issue that was reported by several users on the G+ community but I could never reproduce using the same devices. However I happened to be using the S4 mini on TestObject and here it is.

comment:2 Changed 4 years ago by rjeschke

The S4 mini has _hardware_ keys and therefore does not need a software menu icon, because you can access the menu by pressing the menu key on the phone.

comment:3 Changed 4 years ago by philll

I wonder how those people use other apps. From what I've seen, most apps remove their menu icons from the screen on this kind of phones.

comment:4 Changed 4 years ago by Ross

  • Resolution set to worksforme
  • Status changed from new to closed

Ah, I haven't encountered these devices very often. I tried it out and it works as expected on several of them. I'll close this for now and reply about it on G+.

Note: See TracTickets for help on using tickets.