Opened 4 years ago

Closed 4 months ago

#2969 closed change (rejected)

Notification locales should be interpreted as Mozilla l10n locales

Reported by: fhd Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian, wspee Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Background

We currently pick notification translations based on the current platform's locale. On Firefox that's a Mozilla l10n locale code, and that is the format we want to use in notifications. On other platforms, however, the local locale format is used, which can differ in some subtle ways.

What to change

Interpret the locale code of notification title/message translations as Mozilla l10n locale.

Change History (3)

comment:1 Changed 4 years ago by sebastian

  • Cc sebastian added

Chrome uses basically the same format, except that it uses underscores instead dashes. This conversion however is already performed in Utils.appLocale. Any further conversion should probably go in there as well, rather than implementing a notification specific solution.

But Chrome also combines all dialects of Spanish outside of Spain as es-419, while Firefox distinguishes them as es-AR, es-CL and es-MX. But since es-419 is a superset of these dialects you cannot map it to a single subset. At least this would be inaccurate and confusing. However, alternatively, we could map these subsets to the superset of es-491 in, or (on the server-side) for, Firefox.

comment:2 Changed 2 years ago by sebastian

  • Cc wspee added

Is this still relevant?

I just confirmed that also with WebExtensions on Firefox, es-AR, es-CL and es-MX are separated, while on Chrome they are combined as es-419. If we unify these I still think that we should rather go with Chrome's semantics, as this the only way to achieve consitent semantics across all platforms.

Alternatively, we can leave the implementation alone, and just document the browser inconsistency leaked here in the spec. That way, we can still differentiate different Latin American dialect on Firefox, but if we want to target both Firefox and Chrome with the same notification we just have to target es-419 in addition to es-AR and/or es-CL and/or es-MX.

comment:3 Changed 4 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.