Opened 4 years ago

Closed 4 years ago

#2994 closed defect (rejected)

Fanboy's Lists missing from subscription selection dialog

Reported by: SMed79 Assignee:
Priority: P3 Milestone:
Module: Sitescripts Keywords:
Cc: trev, mapx, arthur, greiner, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by greiner)

Environment

Firefox

How to reproduce

  1. open the Adblock Plus Filter Preferences menu.
  2. click on "Add filter subscription", to open the drop-down menu.
  3. click the link : add another subscription.

Observed behaviour

Fanboy's Annoyance List and Fanboy Social Blocking List are not found.

Expected behaviour

Restore Fanboy's lists.

https://adblockplus.org/forum/viewtopic.php?f=2&t=40269

What to change

Modify the template for subscriptions2.xml to show supplemental subscriptions with types that differ from the base subscription similarly to how we're doing it for adblockplus.org/subscriptions in #2823.

Change History (10)

comment:1 Changed 4 years ago by mapx

  • Cc saroyanm trev added

comment:2 Changed 4 years ago by mapx

  • Cc mapx added
  • Component changed from Unknown to Websites

comment:3 Changed 4 years ago by arthur

  • Cc arthur added

comment:4 Changed 4 years ago by greiner

  • Cc greiner added

I can confirm that this is a regression from #2822 because it should've been dependent on #2823. In any case, #2823 should resolve this issue so as soon as saroyanm sets it to Ready, I can work on getting it under review.

comment:5 Changed 4 years ago by greiner

  • Cc sebastian added; saroyanm removed
  • Component changed from Websites to Sitescripts
  • Description modified (diff)
  • Platform changed from Unknown / Cross platform to Firefox
  • Summary changed from Fanboy's Lists missing on Known Adblock Plus subscriptions to Fanboy's Lists missing from subscription selection dialog

#2823 has now landed so the filter lists show up on adblockplus.org again. I've looked into the necessary changes for fixing the issue in the subscription selection dialog and updated the ticket description accordingly to focus on the issue with the subscriptions selection dialog.

comment:6 Changed 4 years ago by sebastian

  • Priority changed from Unknown to P3
  • Ready set

comment:7 Changed 4 years ago by greiner

  • Owner set to greiner

comment:8 Changed 4 years ago by greiner

@SMed79 I noticed that subscriptions that have a type that's not "ads" are ignored by the extension and therefore not even included in the subscription selection dialog. Are you sure that Fanboy's lists are supposed to be shown in there?

Nevertheless this ticket is still valid because those lists should still be included in subscriptions2.xml even if they're ignored by the extension.

comment:9 Changed 4 years ago by greiner

  • Owner greiner deleted

Unassigning myself since I'm not actively working on it anymore and there's no indication that this is somehow connected to either the new options page or broken functionality.

comment:10 Changed 4 years ago by trev

  • Resolution set to rejected
  • Status changed from new to closed

Actually, this is by design - this list was never meant to display filter subscriptions that aren't meant to block ads, simply because it has no way of explaining what they are good for. The new options page will probably address this issue, but we won't change the behavior before this one is in place.

I'll check why EasyPrivacy and some other lists have been miscategorized there.

Note: See TracTickets for help on using tickets.