Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3030 closed defect (fixed)

Whitelisted Google AdSense text ads not showing up

Reported by: arthur Assignee:
Priority: P2 Milestone: Adblock-Browser-for-iOS-1.1.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: jand, pavelz, vojtab Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

  • iPhone 6 Plus with iOS 9.0 (13A4325c)
  • Adblock Browser v1.0.0 (core 1.2.18)
  • EasyList
  • Acceptable Ads on

How to reproduce

  1. Open Adblock browser
  2. Go to a page where Google AdSense for Content ads are whitelisted via Acceptable ads e. g. the following:

Observed behaviour

Whitelisted AdSense ads are not showing up. In fact sometimes you might see them for a split second before they vanish. The only thing you see then is their placeholder and the "AdChoices" icon combined with a close icon.

Expected behaviour

Whitelisted ads should appear as in the screenshots (taken on Firefox 41 Beta 7, with the user agent of Adblock Browser for iOS and reduced screen size).

My assumptions

Since I saw the ad for a split second, it's a strong indicator that some elment hiding exception rule in the Acceptable Ads whitelist isn't actually applied. It seems to be g.doubleclick.net#@##adunit (which is in the whitelist). If I disable this exception rule in Adblock Plus for Firefox and refresh the page, the ad units look the same as in Adblock Browser on the iPhone (icon and placeholder).

Attachments (4)

aquariophilie.org_on_adblock_browser_ios.PNG (975.4 KB) - added by arthur 4 years ago.
aquariophilie.org_on_firefox.png (238.7 KB) - added by arthur 4 years ago.
gutefrage.net_on_adblock_browser_ios.PNG (145.3 KB) - added by arthur 4 years ago.
gutefrage.net_on_firefox.png (30.3 KB) - added by arthur 4 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by arthur

Changed 4 years ago by arthur

Changed 4 years ago by arthur

comment:1 Changed 4 years ago by fhd

  • Priority changed from P1 to P2

P2 is sufficient.

comment:2 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 4 years ago by jand

Last edited 4 years ago by jand (previous) (diff)

comment:4 Changed 4 years ago by fhd

  • Milestone set to Adblock-Browser-for-iOS-1.1.0
Note: See TracTickets for help on using tickets.