Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3032 closed defect (fixed)

Whitelisted Google AdSense for Search ads not showing up

Reported by: arthur Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.1.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: jand, pavelz, vojtab Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

  • iPhone 6 Plus with iOS 9.0 (13A4325c)
  • Adblock Browser v1.0.0 (core 1.2.18)
  • EasyList
  • Acceptable Ads on

How to reproduce

  1. Open Adblock browser
  2. Go to http://www.gutefrage.net/
  3. Tap on the hamburger menu on the top left
  4. Search for "iphone"

Observed behaviour

Google AdSense for Search ads at the top of the search results don't display properly. The actual links are missing.

Expected behaviour

Google AdSense for Search ads at the top of the search results should be visible properly with links.

My assumptions

It seems Adblock Browser doesn't seem to respect the $document filter option. This exception rule in the Acceptable Ads whitelist @@||google.com/cse?$subdocument,document,domain=gutefrage.net should make sure that everything in the iframe used for the ads is being whitelisted and no element hiding filters are appplied. However, the latter seems to be the case. If I disable @@||google.com/cse?$subdocument,document,domain=gutefrage.net in Firefox and add @@||google.com/cse?$subdocument,domain=gutefrage.net instead, the ads look the same in Firefox as in Adblock Browser on the iPhone. Removing the $document option from that exeption rule causes element hiding to be applied in the iframe. In this case ##a[href^="http://www.google.com/aclk?"] is being applied which hides the ad links in it.

Attachments (2)

gutefrage.net_on_adblock_browser_ios.PNG (225.0 KB) - added by arthur 4 years ago.
gutefrage.net_on_firefox.png (41.3 KB) - added by arthur 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by arthur

Changed 4 years ago by arthur

comment:1 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 4 years ago by jand

Last edited 4 years ago by jand (previous) (diff)

comment:3 Changed 4 years ago by fhd

  • Milestone set to Adblock-Browser-for-iOS-1.1.0
Note: See TracTickets for help on using tickets.