Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3044 closed defect (fixed)

[Adblock Browser for iOS] [URL Search Bar] Clipped text

Reported by: Shikitita Assignee:
Priority: Unknown Milestone: Adblock-Browser-for-iOS-1.2.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: pavelz, vojtab, jand, Shikitita Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

Platform: iPhone 5s
Operating system: iOS 8.4
Browser: Adblock Browser for iOS v.1.1.0 (core 1.3.0)

How to reproduce

  1. Install Adblock Browser for the first time
  2. Change the iPhone's language into Russian, for example
  3. Launch Adblock Browser

Observed behaviour

The string "Search or enter website name" inside the URL search bar is clipped at the beginning and at the end

Expected behaviour

The string should be displayed completely in order to be able to read it

Affected languages: French and Slovak

Attachments (1)

IMG_0104.PNG (41.4 KB) - added by Shikitita 4 years ago.
Clipped Text URL Search Bar

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by Shikitita

Clipped Text URL Search Bar

comment:1 Changed 4 years ago by vojtab

I believe the proper solution for this is to shorten the text for languages which are causing issues here.

Otherwise browser code would have to be changed to e.g. decrease font of the text, such that it could fit the designated area. This could result in text being too small to be comfortably readable + would violate the Adblock Browser design guidelines.

Unlike in other cases, url field cannot be stretched to two rows.

comment:2 Changed 4 years ago by pavelz

Otherwise browser code would have to be changed to e.g. decrease font of the text, such that it could fit the designated area. This could result in text being too small to be comfortably readable + would violate the Adblock Browser design guidelines.

This already had to be done to fix https://issues.adblockplus.org/ticket/3038 So yes, the the design guidelines has already been violated because we cannot maintain the font size. On the other hand, the design was done for english which is very dense language. Verbose language translators will always insist that they cannot shorten because, well, it's their language. So breaking the guidelines temporarily is the only way - the translators must see the GUI inbalances themselves. Then a cooperation must follow - they shorten as much as possible, and the rest must be accounted for in changed design guidelines.

comment:4 Changed 4 years ago by jand

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next
Note: See TracTickets for help on using tickets.