Opened 4 years ago

Closed 4 years ago

#3053 closed defect (fixed)

Inconsistent /var/cache directories

Reported by: matze Assignee: matze
Priority: P1 Milestone:
Module: Infrastructure Keywords:
Cc: fred Blocked By:
Blocking: #3016 Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29328011/

Description

While provisioning notification1 as test for all other filter-servers that are to be provisioned for #3016, the following issue occured:

2015/09/10 11:21:46 [emerg] 17944#0: mkdir() "/var/cache/nginx/notification" failed (2: No such file or directory)

This issue did not occur during the prior tests in Vagrant, and I am still unable to reproduce this issue now. However, I actually saw similar issues with the web::server nodes before: The cms.bin.generate_static_pages cron-job failed because of insufficient permissions for accessing /var/cache, which strangely is not easy to re-produce, even with a box provisioned from scratch.

Looks to me like it's being caused by resource requirements that where implicitly met before for some reason, and thus never got integrated with puppet explicitly. Or the inconsistent behavior is based on which package creates the /var/cache/* path(s) in question first (those are not explicitly ordered during provisioning).

Either way, this should boil down to some explicit file {'/var/cache/*': ...} resources being included in some reasonable place within the Puppet files.

Change History (3)

comment:1 Changed 4 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 4 years ago by matze

  • Cc fhd removed
  • Review URL(s) modified (diff)

comment:3 Changed 4 years ago by matze

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.