Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3060 closed change (fixed)

Notification popup should be closed explicitly

Reported by: fhd Assignee: fhd
Priority: Unknown Milestone: Adblock-Plus-2.6.11-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: greiner, sebastian Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Ross Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29327619/

Description

Background

The notification popup is currently being closed whenever the user clicks on anything else. It is even closed when the browser window didn't have focus, and regains focus. Since it is also impossible to bring the message up again once it is closed, closing it should be an explicit user action.

What to change

Instead of the notification popup disappearing once it loses focus, there should be an explicit close button, and it should stay open until that one is clicked.

Change History (10)

comment:1 Changed 4 years ago by fhd

  • Cc greiner added

comment:2 Changed 4 years ago by fhd

  • Priority changed from P2 to Unknown

comment:3 Changed 4 years ago by fhd

  • Owner set to fhd

comment:4 Changed 4 years ago by fhd

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 4 years ago by fhd

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

Pushed: https://hg.adblockplus.org/adblockplus/rev/5c8f470a2bbf

Wladimir pointed out in the review that he's not happy with this change. I also don't think this is the best we can do yet, but the previous behaviour made it very hard to actually see the notification, that's not ideal either.

comment:6 Changed 4 years ago by Ross

  • Tester changed from Unknown to Ross

Firefox: Working as described. Is not automatically hidden as before. Requires explicit closing by the user.

Chrome: Is hidden as soon as the browser regains focus. Is this change not for/in Chrome yet?

ABP 2.6.10.3979-beta
Firefox 40.0.3 / Windows 7 - 32bit
Firefox 40.0.3 / Ubuntu 14.04 - 64bit

ABP 1.9.2.1482
Chrome 45.0.2454.93 m / Windows 7 - 32bit

comment:7 Changed 4 years ago by Ross

  • Platform changed from Unknown / Cross platform to Firefox
  • Verified working set

Sebastian confirmed Firefox only.

comment:8 follow-up: Changed 4 years ago by sebastian

Yes, this issue is only about Firefox. On Chrome, the notification gets hidden after a few seconds, but can still be found in the notification tray. However, it seems that we can make the notification keep showing until it's explicitly closed on Chrome as well, by giving the notification a priority of 1 or 2. I wonder whether we should do that?

comment:9 in reply to: ↑ 8 Changed 4 years ago by greiner

Replying to sebastian:

Yes, this issue is only about Firefox. On Chrome, the notification gets hidden after a few seconds, but can still be found in the notification tray. However, it seems that we can make the notification keep showing until it's explicitly closed on Chrome as well, by giving the notification a priority of 1 or 2. I wonder whether we should do that?

We're already assigning the highest priority to Chrome notifications with the inline comment stating:

We use the highest priority to prevent the notification from closing automatically

Unfortunately, that doesn't stop Chrome from eventually hiding it in the notification center.

The desktop notification should, however, show up again the next time notifications are loaded because IIRC hiding the notification doesn't trigger the same behavior as closing it.

comment:10 Changed 4 years ago by greiner

  • Cc sebastian added
Note: See TracTickets for help on using tickets.