Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3066 closed defect (fixed)

Adblock Plus for Safari iOS doesn't open beyond splash screen on latest iOS9 update

Reported by: nicole Assignee: fhd
Priority: P1 Milestone: Adblock-Plus-for-iOS-1.0.0
Module: Adblock-Plus-for-iOS/macOS Keywords:
Cc: fhd Blocked By:
Blocking: Platform: iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by philll)

Environment

iPhone 6 plus
iOS 9.1 (13B5110e)
Adblock Plus for Safari iOS Version 1.0.0 (7)

How to reproduce

  1. Open the Adblock Plus for Safari iOS host app

Observed behaviour

Red start screen displays for 10-15 seconds, then disappears. Open apps overview keeps displaying it however. Switching back to it from there let's the phone not accept home button presses any more. You can still go into Safari settings and enable ABP as a content blocker.

Expected behaviour

The app should open normally, showing the instructions on how to enable ABP in Safari content blocking settings and offer the app settings.

Attachments (1)

issue-3066-device-log.txt (3.1 KB) - added by fhd 4 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 follow-up: Changed 4 years ago by fhd

We're unable to reproduce this, even on another iPhone 6 :(

comment:2 in reply to: ↑ 1 Changed 4 years ago by nicole

  • Description modified (diff)

Replying to fhd:

We're unable to reproduce this, even on another iPhone 6 :(

Maybe because I just upgraded to iOS 9.1?

comment:3 Changed 4 years ago by philll

  • Description modified (diff)
  • Platform changed from Safari to Unknown / Cross platform
  • Summary changed from ABP App Doesn't Open to Adblock Plus for Safari iOS doesn't open beyond splash screen on latest iOS9 update

comment:4 Changed 4 years ago by fhd

  • Owner set to fhd
  • Priority changed from Unknown to P1
  • Ready set

Reproducible when installing via HockeyApp - on it. So far, it seems that XCode 7 GM Seed produces broken ad hoc builds - when building the same revision we previously had on HockeyApp in GM seed, the crash happens, too.

comment:5 Changed 4 years ago by fhd

Still happens when exporting the build with XCode 7.1 beta. It does, however, work just fine when deploying directly to an iPhone 6S...

Changed 4 years ago by fhd

comment:6 Changed 4 years ago by fhd

So, the relevant error message from the attached log is:

"XPCErrorDescription" => <string: 0x1a015ee88> { length = 18, contents = "Connection invalid" }

Unfortunately, that doesn't really say too much. It just means the app was hanging and got killed by the system. What made it hang - I can't tell.

comment:7 Changed 4 years ago by fhd

Did some regression testing, and the revision that introduces this issue is b625b5ec62ac.

comment:8 Changed 4 years ago by fhd

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 4 years ago by philll

  • Platform changed from Unknown / Cross platform to iOS

Added newly available platform value.

comment:10 Changed 4 years ago by fhd

  • Milestone changed from Adblock-Plus-for-iOS-next to Adblock-Plus-for-iOS-1.0.0
Note: See TracTickets for help on using tickets.