Opened 2 years ago

Closed 3 months ago

Last modified 3 months ago

#3070 closed change (fixed)

Create Adblock Plus on/off switch

Reported by: sven Assignee: diegocarloslima
Priority: Unknown Milestone: Adblock-Browser-for-Android-1.2.0
Module: Adblock-Browser-for-Android Keywords:
Cc: rjeschke, athornburgh, lisabielik Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Scheer Verified working: yes
Review URL(s):

https://codereview.adblockplus.org/29342912/

Description

Background

There is no possibility to deactivate Adblock Plus yet. On iOS we give users this option in the Adblock Plus settings.

What to change

Create on/off Switch with label "Adblock Plus", which should appear as the first Adblock Plus settings item. Obviously it is turned on by default. If a user deactivates Adblock Plus, all other Adblock Plus setting items should turn in a deactivated mode, so that a user can not click e.g. "More blocking options" after Adblock Plus is deactivated.

Change History (9)

comment:1 Changed 16 months ago by diegocarloslima

  • Owner set to diegocarloslima

comment:2 Changed 16 months ago by diegocarloslima

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 10 months ago by fhd

  • Cc athornburgh lisabielik added

Aaron, Lisa, would you mind double checking that this is the text we want? Isn't it "Ad blocking" we want to enable here, rather than "Adblock Plus"? Do we want to position the ad blocking feature within Adblock Browser as "Adblock Plus"?

comment:4 Changed 10 months ago by lisabielik

Could be wrong, but I'm reading this as: we want to give the user the option to completely disable Adblock Plus, without having to uninstall it. Is that what we want to do here?

A screenshot would be helpful for me.

comment:5 Changed 9 months ago by abpbot

A commit referencing this issue has landed:
Issue 3070 - Create Adblock Plus on/off switch

comment:6 Changed 9 months ago by diegocarloslima

  • Milestone set to Adblock-Browser-for-Android-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 3 months ago by scheer

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Tester changed from Unknown to Scheer

There is no documentation or explanation as to what exactly the wording should be now. So, although I see the feature here, I see no intended behaviour, no text that should be displayed etc, so I am unable to correctly verify this as complete.

comment:8 Changed 3 months ago by diegocarloslima

You mean the wording Block intrusive elements [checkbox] Block intrusive ads and other elements, such as images, on all websites. ? If so, it was changed in #4760

comment:9 Changed 3 months ago by scheer

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Verified working set
  • 'Block intrusive elements [checkbox] Block intrusive ads and other elements, such as images, on all websites.' is now correctly displayed.

adblockbrowser-1.1.1.20170612182010-arm
Galaxy S7
Android 7.0

Last edited 3 months ago by scheer (previous) (diff)
Note: See TracTickets for help on using tickets.