Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3101 closed defect (fixed)

Adblock Browser doesn't accept .club TLD

Reported by: arthur Assignee:
Priority: Unknown Milestone: Adblock-Browser-for-iOS-1.1.0
Module: Adblock-Browser-for-iOS Keywords:
Cc: jand, pavelz, vojtab Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

Environment

iPhone 5 16GB
Adblock Browser 1.1.0
tested via TestObject

How to reproduce

  1. Try to open vivarium.club in Adblock Browser

Observed behaviour

Adblock Browser starts a search query for "vivarium.club" on DuckDuckGo.

Expected behaviour

It should open the domain vivarium.club.

Change History (3)

comment:1 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

https://www.pivotaltracker.com/story/show/103974138

Now it will open .club but also attempt to open any string which looks like sometext.abcdefghij (up to 10 chars after the dot) instead of searching for it. Enumerating all those crazy 100s of new TLDs is unreasonable in scope of current development.
http://newgtlds.icann.org/en/program-status/delegated-strings

Last edited 4 years ago by pavelz (previous) (diff)

comment:2 Changed 4 years ago by fhd

  • Milestone set to Adblock-Browser-for-iOS-1.1.0

comment:3 Changed 4 years ago by arthur

A comment form the user who initially reported this issue to us:

Basically this is not fixed properly and it will just be a matter of time before you will have to re-fix this! The ICANN webpage that the comment refers to shows TLD names of e.g. "SANDVIKCOROMANT" and "BRIDGESTONE" which already exceed the 10-char limit that is imposed now. Basically, I think you need to pass any string (containing at least one dot) first to DNS and see if it resolves, if it doesn't then you can search for it.

You'd have to search through the various RFCs to find the latest definition of what TLDs etc can look like, especially with Internationalized Domain Names added into the mix...

Note: See TracTickets for help on using tickets.