Opened 3 years ago

Closed 3 years ago

#3112 closed change (rejected)

[CMS] Allow testing of sitescripts URL handlers along with a static CMS site

Reported by: kzar Assignee: kzar
Priority: Unknown Milestone:
Module: Sitescripts Keywords: cms
Cc: sebastian, saroyanm, oleksandr Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29328524/
https://codereview.adblockplus.org/29328527/

Description

Background

Our websites are often mostly static with pages generated by the CMS, but they sometimes have a few URLs that are handled dynamically by handlers in the sitescripts repository.

We have the ability to test dynamic URL handlers with the sitescripts/multiplexer.py script and we have the ability to test static websites with the cms/runserver.py script. The problem is that we don't currently have a way to test them both together and how they interact.

What to change

Make changes to cms/runserver.py so that if sitescripts is available and configured the multiplexer can be used to respond to requests. If the sitescripts multiplexer has no available handler then cms/runserver.py should serve the static files / pages as it does currently.

Change History (2)

comment:1 Changed 3 years ago by kzar

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 3 years ago by kzar

  • Resolution set to rejected
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.