Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3123 closed defect (fixed)

Adblock Browser for iOS opens two tabs when tapping external links on facebook

Reported by: philll Assignee:
Priority: P1 Milestone: Adblock-Browser-for-iOS-1.2.0
Module: Adblock-Browser-for-iOS Keywords: salsita
Cc: pavelz, mario Blocked By:
Blocking: Platform: Adblock Browser for iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by philll)

Environment

iPhone 6 Plus
iOS 9.1 (13B5110e)
Adblock Browser v1.1.0 (core 1.3.0)
Original report: https://adblockplus.org/forum/viewtopic.php?f=25&t=40613&p=138944#p138920

How to reproduce

  1. Log in to Facebook.com
  2. Go to https://m.facebook.com/adblockplus
  3. In the about section, tap the URL https://adblockplus.org

Observed behaviour

Two new tabs open with the tapped URL.

Expected behaviour

One new tab should open with the tapped URL.

Change History (12)

comment:1 Changed 4 years ago by philll

  • Description modified (diff)

comment:2 Changed 4 years ago by philll

  • Ready set

comment:4 Changed 4 years ago by pavelz

Can't reproduce. Only one new tab opens for me. Are you logged in FB or anonymous?

comment:5 Changed 4 years ago by philll

  • Cc pavelz added

As described in the How to reproduce section, I was logged in. The behaviour doesn't occur with the public version of the URL.

comment:6 Changed 4 years ago by mario

  • Cc mario added
  • Priority changed from Unknown to P3

Temporarly set to P3 unless we discover, that it's a broader problem and other sites are affected as well.

comment:7 Changed 4 years ago by mario

  • Keywords salsita added

comment:8 Changed 4 years ago by pavelz

  • Priority changed from P3 to P1

comment:9 Changed 4 years ago by pavelz

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 4 years ago by philll

@pavel: Could you please provide some background on this, specifically, why it's a P1 in the end and what areas are affected to allow testers to best do their job.

comment:11 Changed 4 years ago by pavelz

The issue applies to any site which hooks its own generic click handler on documentElement. Facebook specifically wants to run its own window.open on any <a target="_blank"> which is what Kitt core already does for sites not as opinionated as Facebook. Regarding testability, there is no other deterministically known site doing that, an onlick on a specific DOM element is more common practice which does not intersect with this issue. But the click hooking it is a completely legal and expectable activity which was generally mishandled by Kitt core. So it was assigned P1 and fixed preemptively.

comment:12 Changed 4 years ago by mario

  • Milestone set to Adblock-Browser-for-iOS-next
Note: See TracTickets for help on using tickets.