Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3146 closed change (duplicate)

Host Safari content blocker lists on easylist-downloads.adblockplus.org

Reported by: fhd Assignee:
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: matze, fred Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by fhd)

Background

#3093 will make Adblock Plus for iOS download the content blocker lists from easylist-downloads.adblockplus.org. Therefore, we need to host them there. They shouldn't be generated from EasyList automatically at this point, every new version still needs testing for the app to still work.

What to change

  1. Create a repository (e.g. contentblockerlists) for storing our content blocker lists (currently easylist_content_blocker.json' and easylist+exceptionrules_content_blocker.json`.
  1. Offer the two lists in this repository as downloads on easylist-downloads.adblockplus.org, the URL's should be:

Change History (5)

comment:1 Changed 4 years ago by fhd

  • Priority changed from P1 to P2

comment:2 Changed 4 years ago by fhd

  • Description modified (diff)

comment:3 Changed 4 years ago by fhd

  • Description modified (diff)

comment:4 Changed 4 years ago by matze

  • Cc matze fred added
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this one as duplicate of #3088. I will use the description here to update the exiting tickets accordingly.

comment:5 Changed 4 years ago by fhd

Woops :)

Note: See TracTickets for help on using tickets.