Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3148 closed change (fixed)

Text changes for Adblock Plus for iOS

Reported by: lisabielik Assignee: jand
Priority: P2 Milestone: Adblock-Plus-for-iOS-1.0.0
Module: Adblock-Plus-for-iOS Keywords: salsita 2015q4
Cc: Shikitita, pavelz, vojtab, jand Blocked By:
Blocking: Platform: iOS
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by fhd)

There are several text changes that need to be addressed in the Adblock Plus for iOS project. See https://invis.io/DK42KL5NM for reference.

Please change:

-"Don't be afraid, we explain you how." to "Don't worry, we'll show you how."
-"Update Filterlists" to "Update Filter lists"
-"Last filterlist update:" to "Last filter list update:"
-"To enable ad blocking in safari" to "To enable ad blocking in Safari"

Please notify me for a final review when the changes are made.

Change History (10)

comment:1 Changed 2 years ago by pavelz

Adjustments done. Translation resource uploaded to Crowdin with all existing app screenshots. New build is not available yet, so please review the screenshots. I would prefer spinning a new build when there is at least some of the problematic languages available (russian, greek, german)

Issues with Crowdin:

  • there is 3 occurences of "Acceptable Ads" string. It's different placements of the same string. One is having multiple screens linked, other has none. It's hard to recognize in Crowdin which occurence has a screen already linked and which has not.
  • i could not get "About" string to link from screen to translation. Crowdin keeps claiming that there is no "About" string.

Let me know if any of the above would be an impassable problem for the translators. I have no idea what to do about the "About"

comment:2 Changed 2 years ago by philll

  • Platform changed from Unknown / Cross platform to iOS
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Text changes for Adblock Browser for iOS to Text changes for Adblock Plus for iOS

If the requested changes are implemented, this issue is fixed. The comments don't address any part of this issue.

comment:3 Changed 2 years ago by mario

  • Milestone set to Adblock-Plus-for-iOS-1.1.0

comment:4 Changed 2 years ago by fhd

  • Resolution fixed deleted
  • Status changed from closed to reopened

The issue is only fixed if the code was actually reviewed and landed in our repository, that is not the case here.

comment:5 Changed 2 years ago by fhd

  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:6 Changed 2 years ago by fhd

  • Owner set to jand

comment:7 Changed 2 years ago by fhd

  • Priority changed from Unknown to P2
  • Ready set

The pull request also contains changes for making translations possible. We should either move these to a separate issue/PR (preferable), or update this issue here.

comment:8 Changed 2 years ago by fhd

So, looking at the strings above, those changes have already been made. The only thing that is missing is the comma after "To get a better ad blocking experience".

So this issue definitely needs updating, most of the changes it asks for aren't necessary (anymore).

comment:9 Changed 2 years ago by fhd

  • Description modified (diff)
  • Milestone changed from Adblock-Plus-for-iOS-1.1.0 to Adblock-Plus-for-iOS-1.0.0
  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed

I've investigated this a little:

  1. Don't be afraid, we explain you how. has been fixed in https://hg.adblockplus.org/adblockplussafariios/rev/b625b5ec62ac (already in version 1.0).
  2. Update Filterlists was never in the repository to begin with.
  3. Last filterlist update was never in the repository to begin with.
  4. To get a better ad blocking experience use Adblock Browser for iOS was apparently fixed (without me noticing, it's unrelated :( ) as part of https://hg.adblockplus.org/adblockplussafariios/rev/c41afeb72aa0 (will get into the 1.1 release), however, there's one more occurrence of the string that doesn't have the comma in AdblockPlusContainerController.m - I'm not yet sure what that is used for.
  5. To enable ad blocking in safari was fixed in https://hg.adblockplus.org/adblockplussafariios/rev/b625b5ec62ac (already in version 1.0).

So in a nut shell, apart from number 4 above, all of this had already been fixed for version 1.0. Hence I'm removing the comma change from the issue description and closing this issue as fixed in 1.0.

Lisa: I will put up a new devbuild based on our repository soon and let you know that you can double check the strings there. The comma issue should be fixed for the upcoming release, but I'm not sure, you'll see.

Also removing the linked review, it has nothing to do with this issue.

comment:10 Changed 2 years ago by mario

  • Keywords salsita 2015q4 added
Note: See TracTickets for help on using tickets.