Opened 5 years ago

Closed 5 years ago

#316 closed defect (fixed)

Element Hiding Helper broken in SeaMonkey

Reported by: trev Assignee: trev
Priority: P1 Milestone: Element-Hiding-Helper-1.3
Module: Extensions-for-Adblock-Plus Keywords:
Cc: saroyanm Blocked By:
Blocking: #5 Platform:
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5475196005777408/

Description (last modified by trev)

Environment

Element Hiding Helper 1.2.4a.456, SeaMonkey 2.23.

How to reproduce

  1. Activate Element Hiding Helper

Observed behaviour

Following error occurs:

Error: NS_ERROR_FILE_NOT_FOUND: Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIXPCComponents_Utils.import]
Source File: resource://gre/modules/XPIProvider.jsm -> jar:file:///.../elemhidehelper@adblockplus.org.xpi!/bootstrap.js -> jar:file:///.../elemhidehelper@adblockplus.org.xpi!/lib/inspectorObserver.js
Line: 7

Element Hiding Helper menu item doesn't appear in Adblock Plus menu. This is a regression caused by #5 - Inspector integration is being included unconditionally but SeaMonkey (or Thunderbird) doesn't have developer tools.

Expected behaviour

Element Hiding Helper should work in applications other than Firefox as well.

Change History (4)

comment:1 Changed 5 years ago by trev

  • Description modified (diff)

comment:2 Changed 5 years ago by trev

  • Owner set to trev
  • Status changed from new to assigned

comment:3 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from assigned to reviewing

comment:4 Changed 5 years ago by trev

  • Milestone set to Element-Hiding-Helper-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.