Opened 4 years ago

Closed 4 years ago

#3163 closed defect (fixed)

Adapt "Block element" functionality for a change in Chrome dealing with "\0" in CSS selectors

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-for-1.9.4-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown / Cross platform
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

https://codereview.adblockplus.org/29328834

Description

Environment

Chrome 45

How to reproduce

  1. Run the tests
    1. Run .build.py -t chrome devenv
    2. Go to the options
    3. Run document.location = "qunit/index.html" from the JS console
  1. Or, select an element which uses \0 in the id or class with the "Block element" dialog.

Observed behaviour

The CSS escaping tests fail for strings that contain \0.

Moreover, "Block element" might suggest filters relying on attributes containing the invalid \0 character. The resulting element hiding rule however won't match the corresponding element.

In previous versions of Chrome, \0 could be escaped as \\0. However since Chrome 45, \\0 doesn't match anything anymore.

Expected behaviour

The tests should ignore the \0 character. And the "Block element" dialog shouldn't suggest element hiding filters matching ttributes with \0 character.

Change History (3)

comment:1 Changed 4 years ago by sebastian

  • Priority changed from Unknown to P3

comment:2 Changed 4 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:3 Changed 4 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.